Unable to "sudo apt-get update or install"

Hello fellows,
Here’s my issue, I’m on OSMC on Raspberry Pi 2 B+, Linux osmc 4.4.27-5-osmc #1 SMP PREEMPT Tue Nov 22 02:23:12 UTC 2016 armv7l GNU/Linux
So, I logged on via user “osmc” then tried to do some “sudo apt-get update”, also “sudo apt-get install xxxx”, eache time I had the same output, as follows:
Fetched 13.1 kB in 18s (727 B/s)
E: Could not open lock file /var/lib/dpkg/lock - open (2: No such file or directory)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
You may ask if I’m root, since OSMC disable “root” user unless you “sudo passwd root”, I’ve done so and acting under “root@osmc”, but still the same issue.
If there’s anyone that can help me it would be perfect since I need to install some stuffs I sue frequently,
Thanks,

indicates some serious issue suggest to provide full logs with grab-logs -A

Doing a “grab-log -A” results in :slight_smile:dpkg-query: error: failed to open package info file /var/lib/dpkg/status' for _reading: No such file or directory_ _dpkg-query: error: failed to open package info file /var/lib/dpkg/status’ for reading: No such file or directory_
grep: /var/log/apt/term.log: No such file or directory
grep: /var/log/apt/history.log: No such file or directory
Unable to write temporary log to /var/tmp/uploadlog.txt
Failed

Well then your SD card is gone, you could try to reinstall OSMC but my best guess is you need a new SD card

Possibly, I’ll test with a new one and i’ll give a feed-back, thanks for your time and have a nice day :slight_smile:

Hello, samed thing here with another SD Class10 16Gb, may it be the OSMC image ?

You mean new install on a new SD card and you get “/var/lib/dpkg/status’ for _reading: No such file or directory”?
Where are you taking the image from?
Which brand is the card (is it fake)?
Is your Pi powered sufficiently?

Image took from official (the last to date 2016-12-1)
SD is HP original 16Gb Class 10 worked perfectly on previous devices and used for some time as an Ubuntu Mate system
Pi is powered with 5V 2A power supply and a 2.5" HDD hooked to it + K400 Logitech wirless kb (was doing great till now)

Also, I burn manually my image with Win32 utility, wether via the SD reader of the laptop or via the card reader,
I will try with installing utility provided from the official and using an older image

rpi2 and buspowered hdd could be too much for a 2A powersupply…
Your powersupply or sdcard could be dregrading.
Do you see the yellow lightningsymbol in the upper right corner?

Edit: Try to reimage the card with the official installer and then set it up first without the hdd.
If everything works, get a bigger powersupply or a powered hub for your hdd.

OK I’ll try, already burned the image with the official tool, I’ll try without the HDD and give a feed-back
Thanks

Ok let’s play a bit
HDD consumption is 4.5 W, with 5V current gives us around 1A
Raspberry Pi 2 B+ consumption 3.5 W, with 5V current gives us around 0.7 A
Sow, the whole installation has an amperage around 1.7 A, let’s assume there are pics of consumption, 2 A seems to be limit
(The installation is hooked with a Sony HD-E2 HDD enclosure with a 500Gb HSGT HD + a Logitech K400 Unifying dongle + HDMI + Ethernet)

Read the hdd datasheet carefully.
1A might be the consumption while running. But spin up current peaks may be a lot higher.

Edit: Also your powersupply could be going bad.
Measure Voltage while applying a constant load of 2A. Or just try a different one.

Do you see the low power symbol in the top right corner from time to time?

Probably, all these parameters could play a role, I’ll try the installation without the HDD and see if there’s a difference
But the main weared thing, is the “command not found” output, lsusb, for example doesn’t launch

Lsusb is not installed by default.
Install usb-utils.

Edit: Sorry, of course this doesn’t work in your case.

:slight_smile: install doesn’t work

The thousands of people successfully using OSMC seems to indicate that it does.

Rather than writing an image to the SD card, have you tried using the official OSMC installer? This is our preferred way or people installing OSMC.
https://osmc.tv/download/

How old is the SD card and what make/model is it? It could just be a bad card making your install non-functional. I’ve had one of these myself recently where it turned itself read-only and I couldn’t bring it back.

Ah, I see you’ve already tried a different card.

Thanks for your wise words, referring to my version of install who’s not working (for now but i will)
Anyway, I’ve mentioned earlier that I burned the official image without the OSMC utility, but now I’v changed the SD and burned it with the OSMC utility, and have not tested it yet for now,
I’ll give a feed-back this evening :slight_smile:

I must confess that the suspicious faulty card was a µSD used 1 year on a Kodi installation (on RBPi2)
Now I will try with a HP 16Gb Class 10 and see

Good luck.

1 Like