Unable to transfer files to RPI2 (through SMB and FTP)

Hi guys,

So yesterday I installed the RC of OSMC, updaded it, downloaded the FTP and SMB extensions from the App Store, and rebooted to make sure it was running.

My EXT4 external 3.5 hard drive attached to the RPI2 was automounted to /media/My_HDD

I was able to transfert two .mkv files over SMB, but the writting speed was not as great as expected (3.5 to 4.5 MB/s) for a RPI2 with an EXT4 formated hard drive.

When I tried to transfer some more files, I got a message saying that I’d need 44 GB to do that, while I still have 2.6 To available on my hard drive.

Didn’t get much success with FTP, FileZilla could create the directories, get filesize, or create files.

Something that I think might explain all of this is if I was trying to write my data on my SD card instead of my hard drive. But I’m not, I’ve checked and the files I tried to upload via FTP or send via SAMBA were supposed to be written to /media/My_HDD

Anyone has an idea ? Thanks