Unable to update

I have two RP-2 and am unable to update either. Both freeze at 89% when configuring armv7 network OSMC (armhf). I have tried both through the GUI and the consul with the same result.
I have done a fresh install with a number of different 16 gb SD cards and with different power supplies with the same result on both.
One PI has a hard drive attached and a Samsung via HDMI and the other PI has no external drive and an older monitor and video output.
When the update stalls at this point the PI has to be hard booted and will then will not get past the OSMC splash screen. I can log on via the consul though and was wondering if something could be done from there to diagnose the issue.
The only commonality to both PI’s is the network as near as I can tell.

To get a better understanding of the problem you are experiencing we need more information from you. Please see How to submit a useful support request - General - OSMC for advice on how to help us.

I assume i would have to start over from a clean install, run updates with logging enabled and then submit a log obtained via the console since OSMC will not reboot?

Log on using ssh, type grab-logs -A then post the resulting link here.

Only got to 75% this time around.


Can you try manually updating in SSH by issuing
sudo apt-get update && sudo apt-get dist-upgrade
and report back the output?

I get an error stating “dpkg was interrupted, you must manually run ‘sudo dpkg --configure -a’ to correct the problem”.

After running that i get a message asking whether to install a new “/etc/connman.conf” or keep the old one.

I selected “Y” to install new (although I’ve selected “N” previously) but just end up with the command prompt and OSMC will still not reboot regardless.

Here is the latest log. http://paste.osmc.io/iqagejajoc

WOW… Why are you on 14.1 with this install? How old is it?

00:00:39 T:1957060608  NOTICE: Starting Kodi (14.1 Git:Unknown). Platform: Linux ARM (Thumb) 32-bit
00:00:39 T:1957060608  NOTICE: Using Release Kodi x32 build (version for Raspberry Pi)
00:00:39 T:1957060608  NOTICE: Kodi compiled Mar 14 2015 by GCC 4.9.2 for Linux ARM (Thumb) 32-bit version 3.16.7 (200711)
00:00:39 T:1957060608  NOTICE: Running on Open Source Media Center 0.9.9, kernel: Linux ARM 32-bit version 3.18.9-5-osmc

If this install is an RC from pre-stable release, a full re-install is going to have to be done. There is no upgrade path from those old RC builds.

Have you seen an “Unsupported Alpha” Warning at any time?

No unsupported Alpha warning that I’ve noticed.
I’ll download and installl the latest OSMC image and give it another go.
I’ll let you know what happens.

That did the trick ActionA. I’ve been trying to find the problem for some time now.
I couldn’t understand why i was having the same issue on both RP-2’s but now I understand since i was using the same old .img as a starting point.
Thanks a lot for your help, I do appreciate it.

Anytime, glad you are up and running and current again!