Unable to update

Hello all,
I’ve had a look at a few threads and tried some of the suggestions to no avail. If I run the OSMC Update. I get an error “OSMC Update Error” Error Installing, please report this on the OSMC forum.

I tried from SSH and I get the following when I run apt-get update:

Ign http://ftp.debian.org jessie InRelease
Hit http://ftp.debian.org jessie-updates InRelease
Hit http://security.debian.org jessie/updates InRelease
Ign http://download.osmc.tv ./ InRelease
Hit http://ftp.debian.org jessie Release.gpg
Hit http://apt.osmc.tv jessie InRelease
Hit http://ftp.debian.org jessie Release
Hit http://apt.osmc.tv krypton InRelease
Ign http://download.osmc.tv ./ Release.gpg
Ign http://download.osmc.tv ./ Release
Err http://download.osmc.tv ./ Packages

Err http://download.osmc.tv ./ Packages

Get:1 http://ftp.debian.org jessie-updates/main armhf Packages/DiffIndex [9376 B]
Hit http://ftp.debian.org jessie-updates/contrib armhf Packages
Err http://download.osmc.tv ./ Packages

Get:2 http://ftp.debian.org jessie-updates/non-free armhf Packages/DiffIndex [736 B]
Hit http://ftp.debian.org jessie-updates/contrib Translation-en
Get:3 http://ftp.debian.org jessie-updates/main Translation-en/DiffIndex [3688 B]
Get:4 http://ftp.debian.org jessie-updates/non-free Translation-en/DiffIndex [736 B]
Err http://download.osmc.tv ./ Packages

Hit http://security.debian.org jessie/updates/non-free armhf Packages
Err http://download.osmc.tv ./ Packages
404 Not Found
Hit http://security.debian.org jessie/updates/non-free Translation-en
Get:5 http://apt.osmc.tv jessie/main armhf Packages/DiffIndex [2023 B]
Hit http://security.debian.org jessie/updates/main armhf Packages
Hit http://security.debian.org jessie/updates/contrib armhf Packages
Ign http://download.osmc.tv ./ Translation-en
Hit http://security.debian.org jessie/updates/contrib Translation-en
Hit http://security.debian.org jessie/updates/main Translation-en
Get:6 http://apt.osmc.tv krypton/main armhf Packages/DiffIndex [2023 B]
Hit http://ftp.debian.org jessie/main armhf Packages
Hit http://ftp.debian.org jessie/contrib armhf Packages
Hit http://ftp.debian.org jessie/non-free armhf Packages
Hit http://ftp.debian.org jessie/contrib Translation-en
Ign http://apt.osmc.tv jessie/main Translation-en
Hit http://ftp.debian.org jessie/main Translation-en
Hit http://ftp.debian.org jessie/non-free Translation-en
Ign http://apt.osmc.tv krypton/main Translation-en
Fetched 18.6 kB in 8s (2076 B/s)
W: Failed to fetch http://download.osmc.tv/dev/gmc/./Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

This is what my “sources.list” contains
deb http://ftp.debian.org/debian jessie main contrib non-free

deb Index of /debian jessie-updates main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free

deb http://apt.osmc.tv jessie main

deb http://download.osmc.tv/dev/gmc ./
deb http://apt.osmc.tv krypton main

Any ideas?


Are you trying to test a development build? if not remove:

deb http://download.osmc.tv/dev/gmc ./

From sources.

If you are trying to test kodi 18, I think this line needs updating to:

deb http://download.osmc.tv/dev/gmc-18 ./

see here:

Thanks Tom.