Unable to use YouTube add-on


I just installed OSMC on a raspberry pi zero W and everything is working fine.

I was able to watch videos on youtube with the add-on but since yesterday it doesn’t work anymore : I can search for videos but when I try to play, I get an error.

I cleared the youtube cache data base, I tried to activate MPEG-DASH and I verified my API key is ok.

Actualy I can play some youtube videos (the ones that I already played before I guess, for instance this one) but I can’t find new videos that I can play

Here are my logs : https://paste.osmc.tv/tamoxalosi

Also, just a quick question : is i normal than my cpu is close to 100% (with Kodi-cpu higher than 90% most of the time) except when I watch a youtube video (50%CPU when the add-on was working)

Thank you in advance

I found another video that I can play and it is also 480p ! I think the problem must be related to video quality

There seems to be a change on Youtube side. You would need to upgrade to the Alpha version of the Addon if you don’t want to wait for the stable release

Thank you very much I updated the youtube add-on with the alpha (from the zip file) and it worked like a charm !
Will the next stable version override the alpha version when it is out ?

Thanks again !

Not 100% sure, just keep an eye on it in a couple of weeks.

Ok thank you for you answers !