Unbootable Vero

My Vero (version 1) crashed. No video output, no ethernet connection.

Last command I executed was probably:
cat /dev/port

(don’t ask)

Question is: Can I somehow get the device working again? Or is trying to fix it a waste of time (I don’t use the device for anything important, mostly for testing purposes, so wouldn’t be that bad if I broke it).

What I tried so far: Write new image via official osmc installer to the sd card (still no video output/connectivity).

If you power-cycle the Vero1 with the installation CD-card … does the red light of the SPDIF port goes OFF or stays ON?

The red light stays ON.

So, that means the boot loader is not working, sounds very similiar to Update problem and errors - #11 by dandnsmith

Not clear to me what has changed but hope @sam_nazarko can shed some light.
Meanwhile: You have downloaded the newest Windows installer and used latest greatest OSMC version?

Yes, I just downloaded the installer (2 days ago I think) and used the 2017.12-1 image.

The 2017.12 image won’t give you any problems updating

Were you on a really old version before?

I did apt-get dist-upgrade regularly, if that’s what you mean.

Just redownloaded the installer. Complains about mounting problems.


It’s showing as read only. You could try using dd.

I ran the dd command from the log file. It’s booting.

Thanks a lot!