Undefined MySQL error

Hi, Been happy with a vero4kplus and a vero4k using the same Mysql backend for a while now, but just recently some fun has been happening where the plus (which was in charge of updating the library) would not find new movies. Around the same time, I renumbered my network, and had fun where the views in mysql were unowned (as I had to rename the osmc network associated with the user). So I’ve got a potential few things going wrong here and would love some help if I can get it.

Current error:

2021-09-06 09:50:44.066 T:9358     INFO <general>: CleanDatabase: Cleaning videodatabase done. Operation took 00:21
2021-09-06 09:50:44.073 T:9358     INFO <general>: VideoInfoScanner: Finished scan. Scanning for video info took 00:57
2021-09-06 09:50:44.144 T:2682    ERROR <general>: SQL: [xbmc_video119] Undefined MySQL error: Code (1927)
                                                   Query: select idPath from path where strPath='videodb://inprogresstvshows/704/8/'
                                                   
2021-09-06 09:50:44.144 T:2682    ERROR <general>: GetPathId unable to getpath (select idPath from path where strPath='videodb://inprogresstvshows/704/8/')
2021-09-06 09:50:44.144 T:2682     INFO <general>: MYSQL server has gone. Will try 4 more attempt(s) to reconnect.

But I can do this fine:

root@localhost [xbmc_video119]> select idPath from path where strPath='videodb://inprogresstvshows/704/8/';
Empty set (0.001 sec)

Not sure how to debug that one further

And of course I forgot to paste my logs, sorry

https://paste.osmc.tv/fuceboyapi

First thing I’d do is use a static IP for the MySQL server instead of relying on DNS resolution of the host name ‘swamp’

Sam

Wow. I did that just to humour you, Sam.

“They’re right, I should use the static IP, but there’s no way that’s causing the problem, so let’s just do this and we can get back saying OK didn’t fix it, now what?”

And … it totally fixed it.
Thanks!

Glad it’s solved!