Unknown package error during update

Can’t get more details.
How can I force a redownload ?
error happens during linux blue screen (extracting 27%)

Can’t do much without logs I’m afraid. Can you provide the output of the following:

df -h | paste-log
paste-log /var/log/apt/term.log
paste-log /var/log/apt/history.log
sudo journalctl | paste-log

Or just use the My OSMC log uploader and upload all logs.

osmc@osmc:~$ df -h | paste-log
osmc@osmc:~$ paste-log /var/log/apt/term.log
osmc@osmc:~$ paste-log /var/log/apt/history.log
osmc@osmc:~$ sudo journalctl | paste-log

Here are logs.
Thanks for help

Looks like it is trying to update libmono every time you run updates, and presumably not finishing.

The most likely cause is that one of the mono packages is prompting the user to answer a question during the upgrade - a question which you will not be able to see, or answer on the blue update screen, therefore it appears to have hung.

We have taken many steps to ensure that packages won’t prompt with invisible and unanswerable questions (usually default choices and keeping existing configuration files should automatically be chosen) however if a package is not written to proper Debian APT guidelines (or is buggy) it might still prompt in a way that our automatic choices can’t answer.

The easiest short term answer is to upgrade your system from the command line, then you will be able to see and answer whatever question it is asking you:

sudo apt-get update && sudo apt-get dist-upgrade

If you see some errors instead of a question, please post the errors here.


I tried, here is the result osmc@osmc:~$ sudo apt-get update && sudo apt-get dist-upgradeHit http://secu - Pastebin.com

No question asked. still on kodi 15.1…

Kodi 15.1 is the latest version - what version were you expecting ?

Those libmono packages are marked as ‘held back’ for some reason. That will stop them being upgraded.

Did you use ‘apt-mark hold’ to put them on hold ? In any case they are packages not related to or installed by default on OSMC so aren’t an issue with OSMC as such.

Another possible cause is if those packages have new dependencies that require additional packages to be installed - but normally this would be done by dist-upgrade.

Have you made any changes to your /etc/apt/sources.list ?

Sorry for the Kodi version, I was confuse with the 15.2 release. :smirk:

How can I be sure that OSMC is well upgraded ? Because after the freeze during the package install… I can’t go back on this screen…

  • I didn’t get a notification of system being upgraded (Following this : Run script after update? and this was working before)
  • I refer to the following issue, @sam_nazarko said that it will be fixed on this release, but it still happens to me…
    So I think my system is not well updated.

Yes I’ve made some little modification during my Sonarr installation.
I followed that guide : Install Sonarr Raspberry Pi with Mono 3.10 •

So libmono is on hold, to be sure this system will still work.
And a source modification (just an add) to get Sonarr update :

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys FDA5DFFC
echo "deb https://apt.sonarr.tv/ master main" | sudo tee -a /etc/apt/sources.list

btw my sonarr doesnt work anymore now… it’s a mess…

How can I make sonarr and osmc live together ?

Edit : I tried to reinstall libmono but I get this :

osmc@osmc:~$ sudo apt-get install libmono-cil-dev -y
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libmono-cil-dev : Depends: libmono2.0-cil (= 3.10.0-0xamarin2) but it is not going to be installed

and there is a lot of line like that

EDIT : Ok, here is an update. My problem is that sonarr repository contains a specific version of mono and this version create a conflict with the version in Jessie. This clash creates some unmet dependencies, if you upgrade.
So OSMC tried to upgrate it (why not?!), finds it can’t… so it removes all broken packages, an all packages and files that use these packages, including my sonarr installation…
So according to this page (I follow that to install Sonarr) : Install Sonarr Raspberry Pi with Mono 3.10 •

We need to lower pin preference

sudo nano /etc/apt/preferences

Add these lines

Package: *
Pin: release n=jessie
Pin-Priority: 998

Note that wheezy need to be replaced by jessie

Save with Ctrl+X, Y and Enter
Now update packages and install

sudo apt-get update
sudo apt-get install libmono-cil-dev -y

After this, everything is ok. You can remove of empty the preference file. (and your sonarr database is still alive !!!)

For the future update, I will remove sonarr repository from /etc/apt/sources.list.

I would be cautious about pinning. This can cause unintended problems.

I would recommend that once you have the software installed and working that you remove the 3rd party repo so that there is no chance of a conflict during an update. You can always add it back in later if you wish to attempt to manually update that software.