Unknown package install error on update

Been getting this error for the past two or three update cycles but this is the first time I could capture logs. Thanks for your help in advance.


Hmm, these lines stand out to me:

20:51:37.257 T:1958748160   DEBUG: ADDON: cpluff: 'Suspicious plug-in descriptor content in /usr/share/kodi/addons/skin.osmc/addon.xml, line 19, column 2 (ignoring unexpected element assets and its contents).'
20:51:37.268 T:1958748160    INFO: ADDON: cpluff: 'Could not read plug-in directory /usr/lib/kodi/addons: No such file or directory'

The /usr/lib/kodi/addons directory should exist, and the error in the addon.xml is odd, so I’m guessing that either your SD card is starting to fail, or somehow (at least) you OSMC Skin got corrupted.

You best bet is probably to backup /home/osmc/.kodi and reinstall, preferably to a new SD card.

1 Like

That’s a bummer to hear. I’ve just got it set up exactly as I wanted. Is there any harm in not doing so? All the updates have applied correctly as far as I can tell. Just this error always happens.

If the SD card is failing, the harm could be more and more errors, or just a sudden failure.

If you back up your /home/osmc/.kodi directory, most of your customizations would be saved.

Hmm, looking closer at the logs, you might consider removing the un-supported repository and addon :smiley:

Would an add-on cause a package error? They don’t seem like related issues to me.

Not necessarily but your apt logs actually don’t show any errors therefore one of the repositories/addons my mess things up.

I got a similar error, I guess it’s the same error-message?
Is it possible to check logs afterwards? I was not in debug-mode when updating.
This is my first update ever, and I just got my Vero 4K last week.

Sorry, I noticed my 5G wifi was down. Fixed it with a router-reboot and ran the update again, and it worked…