Unsafe unmount Storage Issue

Hello there,

I’ve been a satisfied user of a Vero 4K box for over a year now.

Unfortunately lately I’ve been having connection issues with my HDs (unsafe mounting).

After reading some other threads here in the forum I realised that perhaps my HDs were the problem as they are not self powered (although this has never been an issue before)

I purchased a powered USB hub to mitigate the issue but unfortunately it is still ongoing.

It’s a bit of a lottery at the moment, some evenings I turn on the box and I can watch movies with no issues whatsoever, sometimes the unmounting/mounting behaviour kicks in and won’t let me watch anything. If I reboot the box, sometimes the problem goes away but usually it doesn’t.

I have uploaded a log, I hope I did it correctly.

It would be much appreciated if anyone could assist me here.


Thanks in advance!!!

Have you tried connecting to the other USB port on the Vero or tried using a different cable to plug the hard drive in.

Thanks for the reply.
Yes, I have used 2 different HDs with different cables and I have also switched between both USB outputs in the box. No luck…

How many HDDs are connected?

Which USB hub are you using?

I’d try with one disk attached and see if that helps


I have just one HD connected, the second HD was also connected by itself just for testing.
I purchased a generic 3.0 USB hub to power the external HD.
Nothing else connected to my environment (Vero box + USB Hub + HD)

I would check the hub is providing enough power. Otherwise there may be some connectivity issue inside the hub itself.

Sorry for wasting everybody’s time, I have a faulty USB hub.
I’ll replace it and hopefully solve the issue.