Unstable Wifi connection

I recently bought a wifi dongle, the TP-LINK TL-WN823N. After connecting it to my Rasp (B model), selecting network and giving password, it worked well but just for an hour. Then the link became unstable. SSH hangs when connection is not lost. Ping, both from and to rasp indicates that a lot of data are lost. I tried some investigations:

osmc@osmc:~$ lsmod Module Size Used by bnep 12176 2 bluetooth 436443 5 bnep cfg80211 545192 0 rfkill 25412 4 cfg80211,bluetooth 8192cu 667764 0 evdev 12241 1 bcm2835_thermal 2797 0 bcm2835_gpiomem 3823 0 bcm2835_wdt 4197 0 uio_pdrv_genirq 3846 0 uio 10256 1 uio_pdrv_genirq fuse 111285 1 ipv6 431174 36

osmc@osmc:~$ dmesg|grep rtl [ 7.345456] rtl8192cu driver version=v4.0.2_9000.20130911 [ 8.865124] usbcore: registered new interface driver rtl8192cu [ 12.113403] rtl8192cu_hal_init in 1000ms [ 14.398354] rtl8192c_set_FwJoinBssReport_cmd mstatus(1)

I tried to disable dongle power saving:

sudo nano /etc/modprobe.d/8192cu.conf options 8192cu rtw_power_mgnt=0 rtw_enusbss=1 rtw_ips_mode=1

I also tried the max usb power option in /root/config.txt

(it is not supposed to apply to the rasp B).

Distance between rasp and wifi rooter is about 4 m. in the same room.

Any idea on how to have a stable wifi connection?

Tried a different power supply (2A)?

I just tried two other power supplies, a 1.3 A and a 2.0 A. Still unstable.

Have you seen a rainbow coloured square in the top right corner (which would indicate inadequate voltage / power supply issue)?

Have you tried connecting the wifi adapter through a powered usb hub (so that it is not drawing its power from the Pi directly)?

I kept losing connection with my tplink TL-WDR3600 via wifi.I changed the channel width from AUTO to 20MHZ on the router and the wifi link became stable.

The original Raspberry Pi did not have the coloured square in the top right corner to indicate low voltage. It also doesn’t support max_usb_current=1. On those you need to measure the voltage with a voltmeter:


Also you could try running the Wifi adaptor via a powered USB hub so that it is drawing power from the hub’s power supply instead of the Pi - if that works then it confirms its a power issue.

Unfortunately the original model Pi’s (before the B+ and Pi 2) have very limited current supply ability through the USB ports so some more demanding wifi adaptors will have difficulties trying to power directly off the Pi.

I have a TP-Link Archer C2 and I have to set manually both bandwidth and channel number so that I can get a stable wifi link. Thanks for the tip.

Berto and DBMandrake, I tried with an OTG USB Hub externally powered without change.

1 Like

@Eric_S I’d faced similar problems with TL-WN725N. I’ve to compile a new *.ko file for the my dongle to work. Wifi packets were dropped intermittently. TL-WN823N seems like a very new wifi-dongle. I think OSMC/raspbian works better with older wifi-dongle. Newer ones might not work as smoothly.

The TP-Link TL-WN823N has been supported for a long time in OSMC - I have one and so does @sam_nazarko. It uses the rtl8192cu driver, which is included in OSMC.

Just plugged mine in after not having used it for quite a while and it auto-connected to the wifi (previously configured) first time. As far as we know this adaptor works well in OSMC.

I’ve to apologize to talk something I’m not particularly familiar with. So, to troubleshoot this, we’ve to assume raspberry pi doesn’t differ much between Eric_S’s and DBMandrake’s. The difference could only be the TL-WN823N. Is there a chance that TP-Link using a different chipset or hardware version upgrades, that the current driver unable function properly? Eric_S mentioned that he bought the dongle recently. So there’s no chance at all the current driver might not be able to drive the new wifi-dongle perhaps with hardware version differences? I only wish that we can compare hardware version at least to make sure we’re really talking about the same TL-WN823N with the same hardware version.

Just ignore my trolling, if the problem already been solved, I’m not sure why I’d still have something to say.

The TL-WN823N dongle is not quite new. It seems to be available since 2012. The first problem is that there are several chips inside. At least two versions for this one.

In my case, this is with the rtl8192cu chip already discussed longtime ago.

There may be also troubles with the driver with booth good, bad (and ugly?) drivers. See this page. As lsmod provides 8192cu 667764 0, the good driver is already in OSMC.

After two weeks with fixed bandwidth/channel, the connection is still bad.

What’s more annoying is that:

  • other wifi devices have no problem connecting on the same router. Connection seems to be stable and rate OK, at least enough to saturate my DSL link (12 MBits)
  • the same dongle on my Win7/Laptop is also working fine.

So, up to now, this is this dongle when used with rasp/osmc that is in trouble.

Hi to all, so far i have 2 rpi’s ver1. B and 2 usb dongles RTL8188CUS 802.11n WLAN Adapter.
Until recently no problem, but so far, the connection worked after boot, but after a while i was unable to login.

Following modprobe option for 8192cu module fixed it:
cat /etc/modprobe.d/8192cu.conf
options 8192cu rtw_power_mgnt=0 rtw_enusbss=0

  • reboot

after that, no issues anymore so far.
as far as i found, there was some change in kernel with power safe functions…