Unstable Wifi with latest release OSMC 2015.06-1


After installing the latest release on my Raspberry Pi B+ (512mb) my wifi dongle stopped working. Rebooting, clean install, nothing worked. I could not get the wifi dongle to work anymore. The dongle is working perfectly under linux, windows. So the dongle is good.

Well shit happens, so I bought myself a WiFi dongle from this site. It states that the wifi dongle is fully supported and will be supported in future release.

After getting the dongle I installed it and YESSSSS i got wifi again.

So what the problem you might think?

It stops working when trying to update, trying to stream media. The only thing it is good for is ssh. Everything on the Pi that tries to really make use of the wireless network makes the connection drop. Eventually it will get the connection back, but whatever is was doing stopped because of network issues.

The power supply is a 5v/2.0A and until the latest release everything always worked perfectly. From what I can see, is from the moment it starts using the wireless network intensively the dongle is toggling between power saving and waking up again and so on and so. Until for example the stream stops then it returns to normal. Wifi is no good for the moment.

Any ideas?

We would need to see full debug logs captured after you have reproduced the problem, as well as the exact model number of the wifi adaptor - without this information we have absolutely no way of knowing what your problem might be.

BTW the kernel (and therefore wifi drivers) did not change between RC3 and the 2015-06.1 release.

I tried to generate some debugging logs, damn network kept going down.

After looking at the debugging log, I couldn’t find anything interesting, but the dmesg log did show something interesting.

Not only was it showing a lot of

rtl8192c_dm_RF_Saving(): RF_Save
rtl8192c_dm_RF_Saving(): RF_Normal

messages shortly after each other, but also a lot of

OnDeAuth Reason code(6)
OnDeAuth, STA:00:50:7f:3b:bd:e4, ignore = 0


issue_deauth to the ap=00:50:7f:3b:bd:e4 for the reason(7)
issue_deauth to 00:50:7f:3b:bd:e4

And a lot of

[0]=88 [1]=42 [2]=24 [3]=00 [4]=00 [5]=13 [6]=ef [7]=40 [8]=0d [9]=72 [10]=00 [11]=50 [12]=7f [13]=3b [14]=bd [15]=e4 [16]=00 [17]=11 [18]=32 [19]=18 [20]=42 [21]=f7 [22]=50 [23]=92 [24]=00 [25]=00 [26]=27 [27]=19 [28]=00 [29]=20 [30]=00 [31]=00 error packet header
aes_decipher:mic check error mic[0]: pframe(f0) != message(ec)
aes_decipher:mic check error mic[1]: pframe(1f) != message(74)

messages, which let me to believe it is not a sleep / wake problem but a communication problem with my wifi network.

After fiddling around with some settings on my router, it looks I got it resolved. Will have to do some more testing, but for now it seems stable and I am able stream again.

The setting I changed on my wireless router was a setting called Channel Width. The original setting was 20Mhz, this has never changed since I got the wireless router. After changing it to 20/40Mhz the dongle kept working.

I immediately tried my old wifi dongle, but no luck on that one. That one is still not working.

Have you enabled max_usb_current?

Yes, max_usb_current is enabled, and has been enabled for a long I am running OSMC.

Originally I started out with Openelec but after several issues with the auto updates function I decided to give OSMC a try. That worked flawlessly until I decided to update to the latest version (because of previous issues with auto updates under Openelec, I disabled the auto update function). I can’t remember which version of OSMC I was running before the update to 2015.06-1 but I was definitely not RC3.