Unwanted resolution change

Hi guys,

I’m having a new issue where when I start to watch something, the file will play for a few seconds, then go black with no sound and then my tv will display “resolution not supported. Change the resolution of the external device”.

This error is from the tv, not the Vero. The only way to get a picture back is to reboot the Vero.

It is not consistent, so I’m wondering if it is possible that there is something wrong with a particular video file or if it could be something else.

Without logs it’s impossible to say. But if it’s only happening with one file I’d suspect that file.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks. I’ll set it up and should it happen again, I’ll upload the log immediately afterwards.

Okay, it happened again. I already had the device logging turned on. When it last got this problem, I rebooted it and uploaded the logs.



I don’t see anything obvious in the log, but you didn’t have debug logging turned on. Pleas turn that on.

Also, you didn’t answer if this is a problem with only one (or a few files) or all files?

I’m sorry, I could have sworn I had turned logging on.

Anyway, here it is again, hopefully of more use to you


Oh, it doesn’t seem to matter what file it is. And it is only after a long pause between uses. Perhaps after a late night backup or an automatic update? After it stops working and I reboot, it seems to work fine and I can play file after file. The next day, the same problem arises.

Does it only happen after a TV power cycle?


I don’t think it’s related to the TV itself. I’m starting to think it may be the video file after all.

Okay, the TV has been off for hours, the Vero not (it’s left on all the time). I’ve been watching a particular series, so I tried playing another file and it seemed to work okay. So, I went back to my series and tried a file and after the usual 30 seconds or so, the screen goes black and then I get the resolution error warning on the screen.

What I don’t get is while this error does occur, if I reboot the Vero and go and play the exact same file, it works without issue.

I used MediaInfo to look at the video file and this is what it spat out. I don’t know if it means anything.

You can enable HPD Lock for now to resolve this (reboot afterwards)

The MediaInfo screenshot doesn’t show anything – we’d need to see the text. But if it happens with more than one file then it’s probably not the file.

Does this only happen with one file?


It’s the same issue as I am still having

Please try updating in a couple of days and let us know if the problems persists.

Well, I’ve enabled HPD Lock and the problem seems to have been fixed.

So far so good.


1 Like