Update Error call_parent.py file or directory doesn't exist

Have a raspberry pi 4 with latest OSMC install. First start up worked great, now getting errors left and right. Have tried two different sd cards with fresh installs and get the same error when trying to update that call_parent.py doesn’t exist.

This is not a lot of information to go at. So help us help you by enabling debug logging and post complete logs.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:


I am reading the error from the log viewer add-on as upload logs in OSMC results in an error. It’s error is that there’s bytes that UTF-8 can’t decode.

I’ll try to SSH in today and grab the logs from there.

*Side Note, Most of my OSMC doesn’t work. I can’t update, upload logs, run a backup etc, it all errors out.

This is all the command in SSH provides me with. If I view in log add-on I can see more.


Try manual update

sudo apt update
sudo apt dist-upgrade
1 Like

Thank you for the reply did this all last night and it didn’t fix anything. Update not working is just one of the many problems like the log upload also not working. Almost everything I do in OSMC results in an Error.


I was able to pull this from SSH tail command for just the update error.


Hard to say without full logs but try:

sudo apt-get install --reinstall mediacenter-addon-osmc


Hello Sam,

Tried this still no luck. Was able to figure out how to get the log file from WINSCP.


Have you tried on a fresh install without the pirate add-ons installed?

I tried again last night with a fresh install on a new card using the Raspi Imager and so far so good. Fingers Crossed