Update Error July 2018


#1

Hi,
Today I was trying to update my Vero4K using MyOSMC to OSMCs July Update. Unfortunately, during the update I got the following error message:

An error occurred while installing the following package:
vero3-mediacenter-osmc (17.6.0-53)
Please report this problem on the OSMC forum, making sure to include logs. Attempting to restart Kodi in 30 seconds…

After reboot I tried again without success. I provided the log file here (though removing some paths in case you wonder):
https://paste.osmc.tv/luvolabehu

Thanks!


#2

Looks like a file didn’t download correctly. You’ll need to SSH to the Vero4K and run the following from the command line:

sudo rm /var/cache/apt/archives/vero3-mediacenter-osmc_17.6.0-53_armhf.deb
sudo apt-get dist-upgrade

#3

That seemed to be the problem, now it worked. Thanks a lot!


#4

If corruption requires CLI intervention we need to fix this.

Cc @DBMandrake


#5

Jeez… you are a hard task-master!
It’s eleven on a Saturday night…
Just joking by the way Sam. Keep up the great work, and everyone else.
OSMC is definitely the best version of Kodi I have ever used. 5 Stars.


#6

It’s fine. @DBMandrake only works four days a year.
I wasn’t actually suggesting he tends to this tonight, but rather making sure we make a note of this issue if there is a problem and make sure it’s resolved.

Thanks for your kind words.

Sam


#7

Hi Sam,
Because this was my first post despite being with you since the old days of Raspbmc I wanted to thank you and the whole team for developing such a great pice of software. I really enjoy using Vero4K!


#8

An apt-get clean would have fixed that problem - maybe add this as a GUI option in the updater as a way to reset APT if there are any issues.

As to the original cause - probably either corruption on the SD card (looming SD failure) or corrupted download due to an ISP or local transparent proxy. I’ve seen the same issue at work with our transparent proxy where a deb download ends up getting truncated and the proxy holds onto the truncated version of the file in its cache for dear life.