Update Error - Please report this on the OSMC forum

I am getting an “Error installing” when trying to update OSMC from the interface. I’m also getting quite a few sad face blue screens when restarting. I’m running june 2018 version on raspberry pi 2. My apt logs are below but there doesn’t seem to be anything wrong with it.
https://paste.osmc.tv/kigawehemo

Can you try to update using the commandline? Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

Then type:

sudo apt-get update
sudo apt-get dist-upgrade

and cut and paste any error messages here.

Thank you.

Thank you for your answer. I didn’t get any error message running those commands (I had to correct an issue in /etc/apt/sources.list.d/mono-official.list)

Then you seem to have nothing to worry about.