Update failed. Samba error

I tried to do an update on my OSMC Pi this evening and it failed at 95% with a Samba error. This then prevented the Kodi app on iOS from finding the machine.

I found the logs which said that a couple of folders had incorrect permissions (755 instead of 700) so I fixed these. I’m no Linux expert, search engines help me get everything done.

Anyway, the remote app is running again now, but there is still a Samba issue which is preventing me from performing a system update.

It appears to be a registry issue, but I’m afraid Linux isn’t my thing

Any help appreciated, thank you



Thats already strange

It could be a failing SD Card

Maybe upload full logs grab-logs -A where we might spot something.

Thanks for the reply. I tried grab-logs and it said the folder was not writeable… and I’ve not been able to fix it.

Ok that confirms that the SD card failed.
Suggest to backup the files you need/can and then do a new install on a new SD Card.

Sorry for the late reply. Real life getting in the way.

I was able to change the folder permissions though. The card is a sandisk ultra, only a year old, so hoping it’s not a card failure.

In terms of backup, what exactly do I need to do? I don’t mind a clean installation, but every time I’ve had to do this I lose the stuff recorded on PVR as my NAS runs the TVHeadend stuff. I presume there is a database file somewhere, but I’ve never been able to find it.

Which folder permission did you change? Is grab-logs now working?

You normally should be fine using the backup tool from MyOSMC. While generally it depends if your did your customization only in Kodi or also on the OS.
Generally /home/osmc/.kodi and /etc/ should include most customization.

I’ll have a look.

Unfortunately MyOSMC doesn’t work - the service is always unavailable.

I’ve now picked up a Vero 4k as I couldn’t get a remote to work with the Pi Argon One so I’ll try and backup. The one thing I always lose are the TV recordings which are done with TVHeadend on my NAS rather than on the machine running OSMC.

OK - update to Vero 4k worked copying the .kodi folder across, and the TV recordings are still there - thanks for that.

Only one issue now, that it won’t recognise a USB keyboard. Any thoughts on that please? Thank you!

Is this on the Vero?
Can you try the other USB port?

Some older versions of OSMC on Vero 4K / 4K + had an issue where the white USB port was not working. This was fixed in a software update.


Hey Sam, yes on a Vero 4k (not +)

Both USB ports work with the RC receiver, neither accept the USB keyboard I was using with OSMC on the previous Pi4. I’ll dig out another one and try that, sods law that the keyboard failed at the same time perhaps…

OSMC is up to date.



Hi @sam_nazarko - any more thoughts on the USB keyboard issue please?


I was waiting for you to confirm if the keyboard was indeed problematic.

Did you test if the USB keyboard is working on other peripherals?

Have you tried another USB keyboard on the device?

I’d suggest uploading some logs with the keyboard attached so we can see if it’s detected; as well as let us know the make and model of the keyboard.

If the USB receiver still works on both ports, it’s not a hardware issue with the Vero itself

Oh, apologies. Yes, the keyboard works fine under Windows 10. It’s a Microsoft Wired Keyboard 600.

I’ve just tried a Logitech K120 keyboard and that indeed works fine with OSMC, so for some reason it doesn’t like the Microsoft one.

Okay, so it’s specific to one keyboard.

Some logs would be very helpful otherwise it’s hard to know what’s going on.