Update failing (unknown package)


I’m on OSMC August 2015.08-1, and am unable to update. After accepting the update & reboot prompt, the update process fails with a message of “an error occured while installing the following package: (unknown package)”. It then tells me to report this on the forum, so here we go :).

I should mention that I’ve been putting it off to fix this, so I’ve been getting this message for a while now, retrying every now and then and otherwise just ignoring the update.

Any thoughts as to how I can fix this? Do you need more info from me?


I think the OSMC folks want to see the logs for this, have a look here and provide the missing information.

Hi Jim,

Thanks for that. I’ve uploaded full logs here: http://paste.osmc.io/jugikuhari

What I did was:

  • Turn on debugging
  • Reboot
  • Go to My OSMC > Updates > Scan for updates now
  • Accept the prompt to reboot and install updates

After the update failed my Pi rebooted and I uploaded the full logs. I hope somebody can help me out with what to do.


Multiple errors point towards your Perl installation being messed up. Can you try the following via an SSH connection to force reinstallation of Perl:

sudo apt-get update
sudo apt-get install --reinstall perl-base perl-modules perl

Any errors that happen when trying that, please post them here.

Assuming there are no errors, try updating again afterwards.

Hmm, sudo apt-get update fails:

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

I ran sudo dpkg --configure -a and tried again and succeeded. sudo apt-get install --reinstall perl-base perl-modules perl yielded:

The following packages were automatically installed and are no longer required:
  armv7-libafpclient-osmc libcurl3-gnutls rbp2-image-3.18.13-1-osmc rbp2-image-3.18.9-5-osmc
  rbp2-image-4.1.3-1-osmc rbp2-image-4.1.3-2-osmc
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  rbp2-image-4.2.1-1-osmc rbp2-image-4.2.3-2-osmc
Suggested packages:
  fdutils rbp2-doc-4.2.1-1-osmc rbp2-source-4.2.1-1-osmc rbp2-image-4.2.1-1-osmc-dbg rbp2-manual-4.2.1-1-osmc
  rbp2-doc-4.2.3-2-osmc rbp2-source-4.2.3-2-osmc rbp2-image-4.2.3-2-osmc-dbg rbp2-manual-4.2.3-2-osmc
Recommended packages:
  initramfs-tools linux-initramfs-tool kernel-common
The following packages will be upgraded:
  rbp2-image-4.2.1-1-osmc rbp2-image-4.2.3-2-osmc
2 upgraded, 0 newly installed, 3 reinstalled, 0 to remove and 18 not upgraded.
3 not fully installed or removed.

Since the point was to fix Perl, should I proceed (as there’s no mention of Perl above)?

Get the Deb URLs:

apt-get install --print-uris perl-base perl-modules perl --reinstall | grep http | awk {'print $1'} | tr -d "'"

Download them with wget

Run sudo dpkg -i --force on each Deb.

Then run sudo apt-get -f install

Thanks for your reply, Sam. I printed the URLs, downloaded them and rand dpkg -i [filename].deb on each. I didn’t use --force, since that option apparently doesn’t exist. Running sudo apt-get -f install then exited with errors. I uploaded the result to the pastebin: http://paste.osmc.io/irezenemev.vhdl

Try this:

sudo apt-get -f install libmysqlclient18 --reinstall

Did that, no errors. And now? Run sudo apt-get -f install again?

Edit: I didn’t read that apt-get -f install output completely, upon reading it now it looks as though I am done, correct?

To be sure you can kick off a normal update:

sudo apt-get update
sudo apt-get dist-upgrade

If that goes through without errors then your problem should be repaired and you should be up to date, and updates should work for you in future. The root cause of your problem seems to be that your perl installation got corrupted - perl needs to be working for the manual-update service and kernel package updates to work.

So the solution was to manually do a forced re-installation of perl. The libmysqlclient18 package was stuck in a half installed state probably due to multiple failed attempts to run updates, so it just needed manually reinstalling too.

@DBMandrake @sam_nazarko Yep, that did the trick. Thanks a lot for your help!

Hi guys having same issue of Update failing (unknown package)
logs here: http://paste.osmc.io/kepevofalu

Start a new thread.


I’m going to do a fresh install with a new sd card, as the old one has seen a few power disconnects. I’m assuming this will probably fix my issues, if not I will start a new thread.

On that issue; I am a little confused. Countless times on forums I see people chastised for not searching for a thread that pertains to their issue, however this is the second time now I have been pulled up for posting in an existing thread and told to start a new one. Is this the modus operandi for this forum? If so, that’s cool, I will adjust my forum etiquette for this site.

Cheers for all your hard work guys.

You have hijacked a thread where user has evidently experienced corruption, and in particular Perl based corruption, and have not provided evidence you are experiencing the same situation. There is no evidence at all that your issue is related. All you have done is reduce the likelihood that the original poster will see resolution of their issue by conflating your issue with theirs.

Start a new thread.


No worries Sam. I have no idea how to determine that so was simply going by the threads title, which was the exact message I was receiving from osmc, and hoping my logs showed I was having a similar problem. I can see how that sort of thing might get frustrating for the mods who have a bit more experience in linux related matters.

in the future I will start a new thread as soon as advised to by someone more knowledgeable than myself.

thanks again

No problem, in the interim:

Please try and execute the following commands via SSH

sudo apt-get update
sudo apt-get -y install mediacenter-addon-osmc
sudo reboot

And then try updating via My OSMC -> Updater -> Manual controls -> Scan for updates now. If issues persist, please start a new thread.


Same issue with the October update.
Here is my logs : http://paste.osmc.io/liroyatoto

I don’t see any update errors in your log whatsoever.

The last update completed at 2015-10-29 17:58:04 and was successful according to the log.

But I got the error on the bluesprint screen. waited 30 seconds for reboot and directly upload logs.