Update fails

Hi. I wanted to do the march-update, but it fails. The error is “unknown”, and i should report to the forum.
I activated debug log and tried again, same error. You finde the logs here: http://paste.osmc.io/kifamimiyo

There are no errors in the apt log.

Try logging in over SSH and running:

sudo apt-get update && sudo apt-get -y dist-upgrade and post the full output here.

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

This way worked. I’m running the march-version now.
Here is the ssh-output: http://paste.osmc.io/iliviyiboq.pas
So probably the unsigned moonlight-package caused the error? But this shouldn’t break the osmc-built-in update?

You have non-standard repositories added with missing/incorrect keys. This may cause problems. All the updater does is run that command expecting no errors.

I followed the How-To ([HowTo] Moonlight-Embedded (former Limelight) using Luna Launcher) from the forum, but ok.
Just one more thing: A more meaningful error message would have helped a lot. I.e. “Unexpected input required, use apt-get for more details” or something like that instead of “error: unknown”.

The error message is set by whoever owns the apt package (Debian most likely), it’s not an OSMC thing.

If you add other repositories you really ought to add their keys also or comment out the repository from your sources.list file once you’ve installed the software you added it for.