Update page screwed up

Vero 4K plus.
OS: 2022.03-1
kernel linux 4.9.113-64-osmc


When I go to My OSMC, updates, then there are no options on the screen. All I see is;

                                                                    0% ------------?0?---------

          settings level:

                                                             OK    Cancel    Defaults

The only button on the remote control that works is the return button. Te rest of them have no effect.

I tried to factory reset the unit with an installer file, it ran some installer for a while and it re-booted.
Still the same issue. When I tried to boot with the installer file again, it boot as if there is no usb stick with installer installed.

Since I’m an experienced electronic repair man, is there a reset button on the PCB that can be pushed while booting? ( i got another unit that works well).

Anything I can do ?

I don’t think it’s going to be as involving as that

Can you show us a photo and confirm which skin you’re using?

I’d suggest reinstalling using the latest (June image) from Download - OSMC.

See Reinstalling OSMC - Vero 4K - OSMC.

You say you tried this – could you show a screenshot of the contents of the USB/SD so we can verify the system was reinstalled properly. You don’t copy the installer image over, you need to use the Windows or macOS tool to image the USB/SD so that the installer boots on the device



Hi Sam,

I have found my mistake, the installer is like what Rufus is for Windows, to create a bootable USB stick.

Now things are back to normal, happily

Thanks for your quick responce!

Excellent – glad it’s working well for you now.