Update Problem


I’m having a slight problem with updates on my 4K+. I noticed on MyOSMC that my revision is December 2021, so tried to update. Nothing happened.
I went into command line and tried to update and got the message:

osmc@Vero4KPlus:~$ sudo apt-get update
Hit:1 Index of /debian buster InRelease
Hit:2 Index of /debian buster-updates InRelease
Hit:3 http://security.debian.org buster/updates InRelease
Hit:4 Index of /osmc/osmc/apt buster InRelease
Ign:5 Index of /osmc/osmc/apt buster/main Translation-en
Ign:5 Index of /osmc/osmc/apt buster/main Translation-en
Ign:5 Index of /osmc/osmc/apt buster/main Translation-en
Err:5 Index of /osmc/osmc/apt buster/main Translation-en
404 Not Found [IP: 80]
Reading package lists… Done
W: Conflicting distribution: http://security.debian.org buster/updates InRelease (expected buster/updates but got buster-updates)
W: Conflicting distribution: Index of /osmc/osmc/apt buster InRelease (expected buster but got buster-updates)
E: Failed to fetch http://ftp.fau.de/osmc/osmc/apt/dists/buster/main/i18n/by-hash/SHA256/50fdd227e2079381c8a06d645e9f2086613e45993f71ac8fc68da3fca55ec812 404 Not Found [IP: 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.

I tried the dist-upgrade and got this:

osmc@Vero4KPlus:~$ sudo apt-get dist-upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following NEW packages will be installed:
The following packages will be upgraded:
armv7-bluez-osmc armv7-connman-osmc base-files base-files-osmc bind9-host bzip2 cifs-utils curl dirmngr distro-info-data dpkg gnupg gnupg-l10n gnupg-utils gpg gpg-agent gpg-wks-client
gpg-wks-server gpgconf gpgsm gpgv gzip libbind9-161 libbz2-1.0 libc-bin libc-l10n libc6 libcups2 libcurl4 libdns1104 libexpat1 libfreetype6 libfribidi0 libglib2.0-0 libgmp10 libgnutls30
libgssapi-krb5-2 libicu63 libisc1100 libisccc161 libisccfg163 libk5crypto3 libkrb5-3 libkrb5support0 libldap-2.4-2 libldap-common liblwres161 liblzma5 libmariadb3 libnss3 libntfs-3g883
libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0 libsasl2-2 libsasl2-modules-db libsmbclient libsqlite3-0 libssl1.1 libtiff5 libtirpc-common libtirpc3 liburiparser1 libwbclient0
libxml2 libxslt1.1 locales mariadb-common mediacenter-addon-osmc mediacenter-skin-osmc multiarch-support ntfs-3g openssl policykit-1 python-samba python3-pil samba samba-common samba-common-bin
samba-libs tzdata vero3-mediacenter-osmc vero3-wifi-osmc vero364-kernel-osmc:arm64 xz-utils zlib1g
86 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 258 kB/180 MB of archives.
After this operation, 93.4 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Ign:1 http://security.debian.org buster/updates/main armhf mariadb-common all 1:10.3.36-0+deb10u1
Err:2 http://security.debian.org buster/updates/main armhf libmariadb3 armhf 1:10.3.36-0+deb10u1
404 Not Found [IP: 80]
Err:1 http://security.debian.org buster/updates/main armhf mariadb-common all 1:10.3.36-0+deb10u1
404 Not Found [IP: 80]
Ign:3 Index of /osmc/osmc/apt buster/main armhf base-files-osmc all 3.1.5
Err:3 http://apt.osmc.tv buster/main armhf base-files-osmc all 3.1.5
404 Not Found [IP: 80]
E: Failed to fetch http://apt.osmc.tv/pool/main/b/base-files-osmc/base-files-osmc_3.1.5_all.deb 404 Not Found [IP: 80]
E: Failed to fetch http://security.debian.org/pool/updates/main/m/mariadb-10.3/mariadb-common_10.3.36-0+deb10u1_all.deb 404 Not Found [IP: 80]
E: Failed to fetch http://security.debian.org/pool/updates/main/m/mariadb-10.3/libmariadb3_10.3.36-0+deb10u1_armhf.deb 404 Not Found [IP: 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

The unit still plays everything and seems to work. TrackIt doesn’t seem to work anymore, not sure if the update level has anything to do with that though.

Obviously I should have been keep an eye on things and updated on a more regular basis, my fault there.

Anyone have any thoughts as to how to get it to update to the current revision?


Trakt problems should be temporary as they are currently recovering from an infrastructure crash.

Provide logs for the update issue please.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Apologies for not communicating back, thank you for the response ActionA. I’ve not been back at the house since the issue so I cannot get the logs.
I’ll retrieve and upload them as soon as I can. Thanks again for responding.