Update timeout issue

Hi there

I have an issue with the update process.
Osmc tells me about the update and i accept to install it.
Everything looks fine until it switches to the blue system gui telling me it is checking for packages to install.
This screen gets a timeout after 3 minutes … reboots … and pops a notification about an package installation error and to report it here. So here i am. Fun part of it osmc and kodi both seems to be updatet properly.


Try sudo apt-get update && sudo apt-get dist-upgrade && sudo reboot from SSH. Report any returned errors.

Here we go

Reading state information… Done
Calculating upgrade… The following package was automatically installed and is no longer required:
Use ‘apt-get autoremove’ to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Then nothing timed out?

Nope but it complained about the mentioned package shall i try the autoremove and then update again?

Well, yeah… I’m certain it will return 0 pending though… MyOSMC may still persist with a notification though. You’ll need to force a manual update from the GUI to clear it.

Yes after first automatic update which has the timeout odmc/kodi is indeed refreshed but the notification sticks.
Having a manual check afterwars results in … no updates found… and notification is gone.

On next upgrade story starts again

That’s expected behaviour.

Sure thing, im just curios whats going wrong on the first shot

It’s because you broke APT when you tried to install libqtcore4 libqtgui4 libqt4-network libusb-1.0-0in October.

OSMC’s update system won’t fail under normal conditions (i.e. if you update through OSMC only).

1 Like

Okay, trying to remember what for i needed that packages. You see any chance in fixing this or should i either ignore or redo the box

Well i think this stuff comes from various hyperion tutorials.

You could disable updates in MyOSMC so that the update prompt never appears in the GUI. It will then just be up to you to use the apt-get commands I posted above to receive updates once a month or so… Remember, always dist-upgrade, never simple upgrade.

There’s nothing for us to fix, if you are referring to OSMC.

We’ve solved this with a friendly warning now :slight_smile:

Your system seems OK now, so you should be able to update in future via My OSMC. If you make further changes with APT however, this can’t be guaranteed

I will have an eye on it when the next upgrade arrives.
Thx for your quick replies/help.