Update via OSMC settings

Couldn’t find this anywhere else.

I have tried running update via the OSMC settings app. It seems to be doing something but I have no idea whether or not the prices is complete - has updated or not. There seems to be no notification as such. Mine is set to prompt for everything.

Seems to go from 1-10, downloads something and seems to stop at around 7 and then the progress bad disappears.

I have just tried:

sudo apt-get update; sudo systemctl start manual-update

This seems to have worked.

You need to be more patient - first update takes many minutes on a Pi 1 as it has to download then entire APT cache as we don’t ship with a preinstalled APT cache.

Progress display is less than ideal in earlier versions of the OSMC skin and update addon - both have seen improvements to the update progress but to get the improvements you need to update first! :smile:

If you just tell it to check for updates and come back five minutes later it should be prompting to install something. (But now that you have updated manually there won’t be any updates to find)

Thanks DBMandrake. Initially I had a hunch that maybe it might take longer but never received any prompt to update or reboot to install - even after a few hours.

See how we go now after having completed the manual install. Indeed it took a little time on the PiB but much quicker on Pi2.