Updates fails insufficient space


#1

Tried to update on my Raspberry Pi 2 with a 16Gb SD Card and it just says that it can’t complete update because it has no space.
“Insufficient space for Update to proceed.
Free some storage and try again later.”
It downloads the update but in the end I get this message.
Thought this would fix the problem I’m having in recognizing my external HDD.


OSMC's December update is here
#2

Hi,

Please provide the out of:

df -h

You will need to access the command line:

https://osmc.tv/wiki/general/accessing-the-command-line/

Thanks Tom.


#3

Hi Tom.

Don’t understand what you mean by providing the out of df-h.


#4

Hi,

You need to read the link provided about accessing the commandline, then issue:

df -h

Provide the output here, it will help us work out whats happened to your space.

Thanks Tom.


#5
Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
osmc@osmc:~$ df-h
-bash: df-h: command not found
osmc@osmc:~$ df -h
Filesystem      Size  Used Avail Use% Mounted on
devtmpfs        369M     0  369M   0% /dev
tmpfs           374M  9.5M  364M   3% /run
/dev/mmcblk0p2   14G  2.9G   11G  22% /
tmpfs           374M     0  374M   0% /dev/shm
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs           374M     0  374M   0% /sys/fs/cgroup

#6

HI,

Please issue the following from the commandline:

grab-logs -A

Post the the provided link here.

Are you running a Noobs install?

Thanks Tom.


#7

I run that and nothing happens


#8

And I’m running a direct install from the OSMC website


#9

Fake SD card?


#10

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:


#14

Thank you

https://paste.osmc.tv/tequpivija

And to reply to the previous user it’s a Kingston SD Card


#15

Hi,

Looks like the sd card has failed, the system is unable to mount the boot partition; this is why the update fails.

I suggest starting a fresh with a new SD card.

Thanks Tom.


#16

Ok.

Thanks for all your help.

Keep up the great work.