Updating Vero v1-0 to latest version of Kodi

My OSMC is running Kodi 16.1 RC3 from April 2016 on a VERO v1.0
After not using the Vero for a long while, the apps within no longer work and despite doing an update from within MyOSMC, the update doesn’t find anything.

What is the way for me to upgrade to the latest version of OSMC that will work on the VERO v1.0 that I have?

I am looking for the current lists of streaming services including UKTV Play.

Thanks

There is a 2018-12-01 update on the site you look at the download section and it is the last update released for your device from what i can see, frankly it would be better to invest in the current Vero 4k+ as you have better hardware specs and H265 hardware acceleration over the one you currently have and software support will be current as when the team decide its ready we will get the update to kodi 19 along with the core OS update to go along with it.

There are other operating systems you could try, like LibreELEC. But unfortunately LibreELEC support for i.MX6 is quite experimental at the moment.

Vero 1 is now considered end of-life from an OSMC perspective.

Sam

Sam, I take your point regarding the Vero v1.0 being considered end of life from the company point of view, as my one is nearly 5-years old.

I have recently tried but been unable to get the latest image version for that hardware (2018-12-1) to finish its installation after the “update button” is started. It gets so far and then hangs for hours. Eventually switched off after 9-hours and tried to start again but always hangs at the same point.

Beginning to think it’s not worth my time to take this much further, so rather than having the Vero as my Media Centre, could I re-install some other OS purely for Email and simple web browsing?

I can’t seem to find the Technical Specifications for the old Vero 1, so maybe you could advise where I can see them. From memory, I have a gut feeling the architecture is armhf, so maybe a debian OS might work, but what would I need in the way of microSD card ~ my current one is 8GB?

Your best bet would be to run an OS like Armbian on the device.

Sam, many thanks for the pointer to Armbian. I have visited their website but been unable to fathom out which is the correct image to download.

The nearest thing would seem the Cubox-i (https://www.armbian.com/cubox-i) which looks very much like the Vero v1.0 but in black. Nowhere on their website is there any illustration or mention of the OSMC Vero, so would appreciate clarification whether the Vero v1.0 is indeed the white version specially produced with the OSMC logo without any modifications to the integral circuitry.

Hope you can help me with this, either on the forum or by my email address.

Many thanks
sparkler

The Vero was based on the iMX6 Dual-Lite platform; so any operating system with support for this will work.

Hi Sam,

I’ve got an old Vero1 (as well as my 4k) and just got it back up and running. The website offered me V19 for my Vero1 but tried to install it and it wouldn’t, so I got the latest version 18 and bingo all good.
Vero1 crashes a lot, especially when scanning or updating.
I had issues with Vero1 where I couldn’t run apt-get update or apt-get dis-install and it failed with a bunch of errors - trying to remove needed files and unable to complete.
Also couldn’t stop the media centre to udpate xml files.
This was before I downloaded and installed V18.

I was surprised at the differences between the two models software. Seems to be more XMBC stuff on Vero1.
So questions… obviously I can’t update Vero1 to V19? If it’s running ok should I even bother with Armbian?
Should I update my Vero4k to V19? It’s really stable at the moment and I’m happy with it.
What’s the story with updating via cli and it breaking? I’m a bit frightened to update my 4k. I’m used to working with cli so it’s my preference. Any input?

HTH the OP

Cheers!

There are no more updates for OSMC on Vero 1 anymore, which is why you’re not able to upgrade.
If you force an upgrade via the CLI for an unsupported platform, you will get weird results.

The Vero 4K/4K+ is still officially supported, so updating that shouldn’t be an issue.