Upgrade 19.x 0> 20x

Upgrade goes wrong on couple of ways
(logs will follow this weekend)
I have 2 Verso 2 4K’s, livingroom and bedroom.
Shared database heidisql docker on an unraid system.

DB Settings are the same over both systems.

Started upgrading in the livingroom:

  • Database upgrade goes wrong, xxxtablexxx_views are not created while upgrading the database
    (had them hacked in some otherway)

Then upgrade bedroom:

  • Start upgrade, al goes well (it seems)
    After restart, i get again a screen with a database migration ?? (same settings as livingroom)
    Restart again, no content (probably some db error), but worst, when navigating by hand to movie/series, tried several, i get the sad face, so not playing content anymore.
    (log will folow)


If you’re manually editing database tables this sounds like a very specific issue.

Hard to say what the issue is without logs and without knowing what changes you made, but hopefully you dumped the database before upgrade and before making any further changes


The old DB is still there, Kodi/OSMC makes new database (example MyVideos118, MyVidoes221) for an upgrade.
I did not edit the tables manually i’ve added the views which were not created with the migration.
Have to go in the logs for the upgrade of the bedroom osmc

The bug is that the database migration fails to migrate eveything without telling the user about the error. So you end up with a visible “empty” library.

The error of the missing table/view etc in the database is also not visible when restarting OSMC.
An error like this shoud be made visible to the end user, so we do not have to figure out why the library seems to be empty, while it is not.

If a database upgrade failed this can sometimes lead to subsequent upgrades failing as the first thing it tries to do is try to create a database that already exists and stops. Have you tried just dropping the 121 sql db and seeing if succeeds then? If not, I would try having a PC running Kodi do the upgrade as I’ve seen it fail from one platform while working from another.

ah ok, gonna try that yes, if not i just use a new empty db.
i have the pllugin to export the seen state so not a big problem.

Make sure the user you are using has full rights ( GRANT ALL ON *.*) on the whole database (not only the specific tables)

Had to update the mariadb docker first.
after that i ugraded with the WIndows Kodi Client

everything is ok now

1 Like