Upgrade error with bluetooth - sad face reboot loop

Last night OSMC prompted me to update. The update encountered an error mentioning there was an issue with bluetooth 5.23 (if I recall correctly). I did not have time to capture the entire error, as the computer rebooted automatically. Now it just shows me a sad face and looks like it is in a reboot loop.

What can I do to correct this? Is there a way to enter a debugging mode? I’m pretty decent with linux. Will I need to reinstall? Does this sound like a hardware issue? I’m running a raspberry Pi 3.

Can you SSH? Provide the output of grab-logs -A

I attempted to ssh in as the osmc user. I was prompted with the password prompt, when I typed the default osmc password. It immediately kicked me out rather than reprompt me for a password. When I tried to login as root or any other user failed password attempts would reprompt for a password.

osmc@192.168.1.101's password:
Authentication failed.

And the ssh connection would immediately close.
I don’t know why a failed authentication for the osmc user would immediately disconnect and not prompt again, when any other user would retry. Maybe it is an ssh config setting that does not allow remote access or something.

I also tried pressing esc on the sad face screen and that showed me a prompt. I got a command line with a user login. I typed osmc as the user I wanted, and immediately after I clicked enter, it would clear the screen and not give me a password prompt. It would just ask again for the user name.

The Bluetooth error I encountered, during upgrade, said I should report the error here on this forum. Unfortunately, I have this sinking feeling that I’m going to need to reinstall, considering that I am unable to login.

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

If you have a keyboard handy, you may be able to login.

Edit: just read above. It sounds like a possible corruption with your SD card or filesystem

I powered the raspberry pi down and pulled the SD card, and put the card back in. When I powered it up, everything worked fine. I was able to install the new update. I have no idea what happened, but the problem is resolved. I will keep an eye on the SD card. Thanks for the ideas.

I would definitely check this twice. Reboot and check if all packages are still up to date.