Upgrade problem rbp2-mediacenter-osmc

After executing apt-get dist-upgrade, I get an error with the rbp2-mediacenter-osmc package.
Possibly someone else has an idea what I can try?
Otherwise I guess I have to install osmc from scratch :confused:

What I have tried so far:

apt-get dist-upgrade:

Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 rbp2-device-osmc : Depends: rbp2-mediacenter-osmc but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

apt --fix-broken install

Removing rbp2-device-osmc (1.5.7) ...
WARNING: You have tried to remove a package that is essential to OSMC's operation.
To undo these changes, run 'sudo apt-get -f install'.
dpkg: error processing package rbp2-device-osmc (--remove):
 installed rbp2-device-osmc package pre-removal script subprocess returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

apt-get -f install:

Removing rbp2-device-osmc (1.5.7) ...
WARNING: You have tried to remove a package that is essential to OSMC's operation.
To undo these changes, run 'sudo apt-get -f install'.
dpkg: error processing package rbp2-device-osmc (--remove):
 installed rbp2-device-osmc package pre-removal script subprocess returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

apt-get -f install rbp2-device-osmc --reinstall

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 rbp2-device-osmc : Depends: rbp2-mediacenter-osmc but it is not going to be installed
                    Depends: edid-decode but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

apt-get install rbp2-mediacenter-osmc --reinstall

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 rbp2-mediacenter-osmc : Depends: python-is-python3 but it is not going to be installed
                         Depends: libpython3.9 but it is not going to be installed
                         Depends: libsmbclient but it is not going to be installed
                         Depends: samba-common-bin but it is not going to be installed
                         Depends: libcdio19 but it is not going to be installed
                         Depends: mediacenter-addon-osmc (>= 3.0.39) but it is not going to be installed
                         Depends: libnfs13 but it is not going to be installed
                         Depends: libfmt7 but it is not going to be installed
                         Depends: libudfread0 but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).


Please post full logs so we can see why this issue is occuring.




thanks for the feedback!
Which logs u need, the full output of the commands or some log files?

Sorry for this question.

Well, the OSMC GUI didnt work anymore:
ā€œfailed to start raise network interfaces.
failed to start Lighttpd Daemonā€

And grab-logs isnt available at the CLIā€¦
I found an backup (6 months old) and restored it, then apt-get update && apt-get dist-upgrade again.
Same error again!

Thats frustrating

That would indicate a major issue with either certain parts of the OS being removed or an SD Card failure.

That is not a standard OSMC package

Maybe try grab-logs -A before and after the upgrade.

Yes lighttpd is for pihole

I will restore the backup againā€¦ and post grab-logs -A before the update. After upgrade is not possible I think.

I think I have found the problem.
When I run apt-get dist-upgrade, I get following output. When I confirm this, I have the problem.
Does anyone have an idea why all the packages should be removed and how I can resolve this?

grab-logs -A: https://paste.osmc.tv/yitegawobu

Reading package listsā€¦ Done
Building dependency tree
Reading state informationā€¦ Done
Calculating upgradeā€¦ Done
The following packages were automatically installed and are no longer required:
aptitude-common armv7-libbluray-osmc armv7-librtmp-osmc armv7-libshairplay-osmc armv7-libsqlite-osmc bsdmainutils
galera-3 gcc-10-base gcc-11-base gcc-9-base ifupdown libaacs0 libaio1 libasan5 libasound2 libasound2-data libass9
libatomic1 libavahi-compat-libdnssd1 libbind9-161 libboost-iostreams1.67.0 libboost-system1.67.0 libcc1-0
libcdio18 libcdio19 libcec4 libclass-factory-util-perl libconfig-inifiles-perl libcroco3 libcrossguid0
libcwidget3v5 libdbusmenu-glib4 libdbusmenu-gtk3-4 libdns1104 libdns1110 libegl1-mesa libevent-2.1-6 libfam0
libfdk-aac1 libfstrcmp0 libgeoip1 libgif7 libgomp1 libhogweed4 libicu63 libidn11 libimagequant0 libip4tc0
libip6tc0 libiptc0 libirs161 libisc1100 libisc1105 libisccc161 libisccfg163 libiso9660-11 libjson-c3 libjte1
libldb2 liblua5.2-0 liblwres161 libmad0 libmariadb3 libmicrohttpd12 libmpdec2 libncurses5 libnettle6 libnfs12
libnspr4 libnss3 libogg0 libpcrecpp0v5 libperl5.28 libplist3 libprocps7 libpython2-dbg libpython2.7-dbg
libpython3.7 libpython3.7-minimal libpython3.7-stdlib libpython3.9 libreadline5 libreadline7 libsamplerate0
libsigc+Ā±2.0-0v5 libsmbclient libsnappy1v5 libssh-4 libtdb1 libtinyxml2.6.2v5 libubsan1 libunique-1.0-0
libvorbis0a libvorbisenc2 libwebpdemux2 libwebpmux3 libwnck-common libwnck22 libxapian30 libxcb-util0 libyajl2
mariadb-common mariadb-server-core-10.3 mediacenter-eventclients-common-osmc mediacenter-send-osmc
mediacenter-skin-osmc mysql-common ncal netcat-traditional perl-modules-5.28 python-apt-common python2-dbg
python2.7-dbg python3-certifi python3-chardet python3-ldb python3-pexpect python3-pil python3-pkg-resources
python3-ptyprocess python3-requests python3-samba python3-talloc python3-tdb python3-unidecode python3.7-minimal
rbp2-libcec-osmc rbp2-mesa-osmc samba-common samba-common-bin samba-libs socat xfce4-notes xfce4-panel
Use ā€˜apt autoremoveā€™ to remove them.
The following packages will be REMOVED:
aptitude build-essential g++ g+Ā±8 gcc gcc-8 libapache2-mod-php7.3 libexo-1-0 libexo-helpers libgcc-8-dev libldb1
libpolkit-backend-1-0 libpython-dbg libpython-dev libpython-stdlib libstdc+Ā±8-dev mariadb-client-10.3
mariadb-client-core-10.3 mariadb-server mariadb-server-10.3 mediacenter-addon-osmc perl-modules-5.24 php7.0-cgi
php7.0-cli php7.0-common php7.0-json php7.0-opcache php7.0-readline php7.0-xml php7.3 php7.3-cgi php7.3-cli
php7.3-common php7.3-intl php7.3-json php7.3-opcache php7.3-readline php7.3-sqlite3 php7.3-xml python
python-crypto python-crypto-dbg python-dbg python-dev python-ldb python-minimal python-pip python-samba
python-talloc python-tdb python-wheel python3-apt python3.7 rbp2-device-osmc rbp2-mediacenter-osmc
The following NEW packages will be installed:
armv7-evrepeat-osmc bind9-dnsutils bind9-libs bsdextrautils gcc-9-base libapache2-mod-php7.4 libbpf0 libcbor0
libcdio19 libcec6 libcrypt-dev libcrypt1 libctf-nobfd0 libctf0 libdata-validate-ip-perl libdbusmenu-glib4
libdbusmenu-gtk3-4 libdeflate0 libdns1110 libdw1 libevent-2.1-7 libfcgi0ldbl libfdk-aac2 libffi7 libfido2-1
libgarcon-gtk3-1-0 libgdk-pixbuf-2.0-0 libgdk-pixbuf-xlib-2.0-0 libhogweed6 libicu67 libip4tc2 libip6tc2
libisc1105 libjson-c5 libjte2 libldb2 liblist-moreutils-xs-perl liblua5.3-0 libmath-base85-perl libmaxminddb0
libmd0 libmpdec3 libnet-ipv6addr-perl libnet-netmask-perl libnetaddr-ip-perl libnettle8 libnetwork-ipv4addr-perl
libnsl-dev libnsl2 libperl5.32 libprocps8 libpython3.9 libpython3.9-minimal libpython3.9-stdlib libreadline8
libtirpc-dev liburi-encode-perl libuv1 libxcb-util1 libxfconf-0-3 libxpresent1 libxstring-perl libxxhash0 logsave
mailcap media-types ncal perl-modules-5.32 php7.4 php7.4-cgi php7.4-cli php7.4-common php7.4-intl php7.4-json
php7.4-opcache php7.4-readline php7.4-sqlite3 python3-ldb python3-samba python3-talloc python3-tdb python3.9
python3.9-minimal rbp2-image-5.10.78-7-osmc runit-helper xfce4-helpers
The following packages have been kept back:
apt apt-utils cpp galera-3 gcc-12-base libgl1-mesa-dri
The following packages will be upgraded:
adwaita-icon-theme apache2 apache2-bin apache2-data apache2-utils aptitude-common armv7-bluez-osmc
armv7-bluezalsa-osmc armv7-connman-osmc armv7-diskmount-osmc armv7-eventlircd-osmc armv7-irqbalance-osmc
armv7-libbluray-osmc armv7-librtmp-osmc armv7-libshairplay-osmc armv7-libsqlite-osmc armv7-lirc-osmc
armv7-network-osmc armv7-remote-osmc armv7-splash-osmc armv7-udisks-glue-osmc armv7-udisks-osmc avahi-daemon
base-files base-files-osmc base-passwd bash bind9-host binutils binutils-arm-linux-gnueabihf binutils-common
bsdmainutils bsdutils busybox bzip2 ca-certificates cec-utils cifs-utils console-data console-setup
console-setup-linux coreutils cron curl dash dbus dbus-user-session dbus-x11 dconf-gsettings-backend dconf-service
ddclient debconf debian-archive-keyring debianutils desktop-file-utils dialog diffutils dirmngr distro-info-data
dmsetup dns-root-data dnsutils dosfstools dpkg dpkg-dev e2fsprogs eject exfat-fuse exfat-utils exo-utils
fake-hwclock fbset fdisk findutils fontconfig fontconfig-config fonts-dejavu-core fuse gawk gir1.2-glib-2.0 git
git-man glib-networking glib-networking-common glib-networking-services gnupg gnupg-l10n gnupg-utils gpg gpg-agent
gpg-wks-client gpg-wks-server gpgconf gpgsm gpgv grep groff-base gsettings-desktop-schemas gtk-update-icon-cache
gzip hdparm hfsprogs hfsutils hostname idn2 ifupdown init-system-helpers iproute2 iptables iptables-persistent
iputils-ping ir-keytable iso-codes jq kbd keyboard-configuration keyutils kmod less libacl1 libaio1
libalgorithm-c3-perl libapache2-mod-php libapparmor1 libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap
libarchive-zip-perl libasan5 libasound2 libasound2-data libass9 libassuan0 libatk-bridge2.0-0 libatk1.0-0
libatk1.0-data libatspi2.0-0 libattr1 libaudio2 libaudit-common libaudit1 libavahi-client3 libavahi-common-data
libavahi-common3 libavahi-compat-libdnssd1 libavahi-core7 libb-hooks-endofscope-perl libb-hooks-op-check-perl
libbind9-161 libbinutils libblkid1 libbluetooth3 libbrotli1 libbsd0 libburn4 libbz2-1.0 libc-bin libc-dev-bin
libc-l10n libc6 libc6-dev libcairo-gobject2 libcairo2 libcap-ng0 libcap2 libcap2-bin libcgi-pm-perl
libclass-c3-perl libclass-factory-util-perl libclass-inspector-perl libclass-method-modifiers-perl
libclass-singleton-perl libcolord2 libcom-err2 libconfig-inifiles-perl libconfuse-common libconfuse2
libcryptsetup12 libcups2 libcurl3-gnutls libcurl4 libdaemon0 libdata-dump-perl libdata-optlist-perl
libdate-manip-perl libdatetime-format-builder-perl libdatetime-format-iso8601-perl
libdatetime-format-strptime-perl libdatetime-locale-perl libdatetime-perl libdatetime-timezone-perl libdatrie1
libdb5.3 libdbd-sqlite3-perl libdbi-perl libdbus-1-3 libdbus-glib-1-2 libdconf1 libdebconfclient0
libdevel-callchecker-perl libdevel-stacktrace-perl libdevmapper1.02.1 libdpkg-perl libdrm-amdgpu1 libdrm-common
libdrm-etnaviv1 libdrm-nouveau2 libdrm-radeon1 libdrm2 libdynaloader-functions-perl libedit2 libegl-mesa0 libegl1
libegl1-mesa libelf1 libencode-locale-perl libepoxy0 liberror-perl libevdev2 libexif12 libexo-2-0 libexo-common
libexpat1 libexpat1-dev libexporter-tiny-perl libext2fs2 libfcgi-perl libfdisk1 libfile-chdir-perl
libfile-homedir-perl libfile-listing-perl libfile-sharedir-perl libfile-slurp-perl libfontconfig1 libfontenc1
libfreetype6 libfribidi0 libfstrcmp0 libfstrm0 libfuse2 libgarcon-1-0 libgarcon-common libgbm1 libgcrypt20
libgdbm-compat4 libgdbm6 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgeoip1 libgif7 libgirepository-1.0-1 libgl1
libgl1-mesa-glx libglapi-mesa libglib2.0-0 libglu1-mesa libglvnd0 libglx-mesa0 libglx0 libgmp10 libgnutls30
libgpg-error0 libgpm2 libgraphite2-3 libgssapi-krb5-2 libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libgtk-3-0
libgtk-3-common libgtk2.0-0 libgtk2.0-common libgtksourceview-3.0-1 libgtksourceview-3.0-common libgudev-1.0-0
libharfbuzz0b libhtml-form-perl libhtml-parser-perl libhtml-tagset-perl libhttp-cookies-perl libhttp-daemon-perl
libhttp-date-perl libhttp-message-perl libice6 libidn11 libidn2-0 libinput-bin libinput10 libio-html-perl
libio-sessiondata-perl libio-socket-ssl-perl libiptc0 libirs161 libisccc161 libisccfg163 libiso9660-11 libisofs6
libjansson4 libjpeg62-turbo libjq1 libjson-glib-1.0-0 libjson-glib-1.0-common libjson-perl libk5crypto3
libkeyutils1 libkmod2 libkrb5-3 libkrb5support0 libksba8 liblcms2-2 libldap-2.4-2 libldap-common
liblist-moreutils-perl liblmdb0 liblocale-gettext-perl liblua5.2-0 liblwp-mediatypes-perl
liblwp-protocol-https-perl liblwp-useragent-determined-perl liblwres161 liblz4-1 liblzma5 liblzo2-2 libmagic-mgc
libmagic1 libmailtools-perl libmariadb3 libmicrohttpd12 libmnl0 libmodule-implementation-perl libmount1 libmpc3
libmpfr6 libmtdev1 libnamespace-autoclean-perl libncurses5 libncurses6 libncursesw5 libncursesw6 libnet-http-perl
libnet-ssleay-perl libnetfilter-conntrack3 libnewt0.52 libnfsidmap2 libnftnl11 libnghttp2-14 libnl-3-200
libnl-genl-3-200 libnl-route-3-200 libnotify4 libnpth0 libnspr4 libnss-mdns libnss-myhostname libnss3
libntfs-3g883 libogg0 libonig5 libopts25 liborc-0.4-0 libossp-uuid-perl libossp-uuid16 libp11-kit0 libp8-platform2
libpackage-stash-perl libpam-modules libpam-modules-bin libpam-runtime libpam-systemd libpam0g libpango-1.0-0
libpangocairo-1.0-0 libpangoft2-1.0-0 libparams-classify-perl libparams-util-perl libparams-validate-perl
libparted2 libpciaccess0 libpcre2-8-0 libpcre3 libpcrecpp0v5 libpcsclite1 libperlio-gzip-perl libpipeline1
libpixman-1-0 libpkcs11-helper1 libplist3 libpng16-16 libpolkit-agent-1-0 libpolkit-gobject-1-0 libpopt0
libprotobuf-c1 libproxy1v5 libpsl5 libpython-all-dev libpython2-dbg libpython2-dev libpython2-stdlib libpython2.7
libpython2.7-dbg libpython2.7-dev libpython2.7-minimal libpython2.7-stdlib libpython3-stdlib libqrencode4
librest-0.7-0 librole-tiny-perl librsvg2-2 librsvg2-common librtmp1 libsamplerate0 libsasl2-2 libsasl2-modules-db
libsbc1 libscalar-list-utils-perl libseccomp2 libselinux1 libsemanage-common libsemanage1 libsensors-config
libsensors5 libsepol1 libsgutils2-2 libsigc+Ā±2.0-0v5 libsigsegv2 libslang2 libsmartcols1 libsmbclient
libsnappy1v5 libsodium23 libsoup-gnome2.4-1 libsoup2.4-1 libspecio-perl libsqlite3-0 libss2 libssh-4 libssh2-1
libssl1.1 libstartup-notification0 libsub-identify-perl libsub-install-perl libsub-name-perl libsub-quote-perl
libsystemd0 libtag1v5 libtag1v5-vanilla libtagc0 libtalloc2 libtasn1-6 libtdb1 libterm-readkey-perl
libtest-fatal-perl libtevent0 libtext-iconv-perl libthai-data libthai0 libthunarx-3-0 libtiff5 libtimedate-perl
libtinfo5 libtinfo6 libtinyxml2.6.2v5 libtirpc-common libtirpc3 libuchardet0 libudev1 libunistring2 libunwind8
libupower-glib3 liburi-perl libusb-1.0-0 libutempter0 libuuid1 libvariable-magic-perl libvorbis0a libvorbisenc2
libvte-2.91-0 libvte-2.91-common libwacom-common libwacom2 libwayland-client0 libwayland-cursor0 libwayland-egl1
libwayland-server0 libwbclient0 libwebp6 libwebpdemux2 libwebpmux3 libwnck-3-0 libwnck-3-common libwrap0
libwww-perl libx11-6 libx11-data libx11-xcb1 libxapian30 libxau6 libxaw7 libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0
libxcb-present0 libxcb-render0 libxcb-shape0 libxcb-shm0 libxcb-sync1 libxcb-xfixes0 libxcb1 libxcomposite1
libxcursor1 libxdamage1 libxext6 libxfce4panel-2.0-4 libxfce4ui-2-0 libxfce4ui-common libxfce4util-common
libxfce4util7 libxfixes3 libxfont2 libxi6 libxkbcommon0 libxkbfile1 libxml-dom-perl libxml-libxml-perl
libxml-libxslt-perl libxml-namespacesupport-perl libxml-parser-perl libxml-perl libxml-regexp-perl
libxml-sax-base-perl libxml-sax-perl libxml-twig-perl libxml-writer-perl libxml2 libxmltv-perl libxnvctrl0
libxres1 libxslt1.1 libxt6 libxtables12 libzstd1 lighttpd linux-libc-dev locales locate login lsb-base lsb-release
lsof make man-db mariadb-common mawk mediacenter-eventclients-common-osmc mediacenter-send-osmc
mediacenter-skin-osmc mime-support mount mousepad mysql-common nano ncurses-base ncurses-bin net-tools netbase
netcat netcat-openbsd netcat-traditional netfilter-persistent nfs-common niceprioritypolicy-osmc ntfs-3g ntp
openssh-client openssh-server openssh-sftp-server openssl openvpn passwd patch perftune-osmc perl perl-base
perl-openssl-defaults php php-cgi php-common php-intl php-sqlite3 pinentry-curses policykit-1 procps psmisc
python-all python-all-dev python-apt-common python-pip-whl python-pkg-resources python-setuptools python2
python2-dbg python2-dev python2-minimal python2.7 python2.7-dbg python2.7-dev python2.7-minimal python3
python3-certifi python3-chardet python3-dbus python3-gi python3-idna python3-minimal python3-pexpect python3-pil
python3-pkg-resources python3-ptyprocess python3-requests python3-six python3-unidecode python3-urllib3
rbp-bootloader-osmc rbp-userland-osmc rbp2-armmem-osmc rbp2-ftr-osmc rbp2-kernel-osmc rbp2-libcec-osmc
rbp2-mesa-osmc readline-common resolvconf ristretto rpcbind rsync samba-common samba-common-bin samba-libs
sensible-utils shared-mime-info socat sqlite3 ssh-app-osmc sudo systemd systemd-sysv sysvinit-utils tar thunar
thunar-data tightvncserver tzdata ucf udev ufw unzip util-linux vim vim-common vim-runtime wget whiptail
wpasupplicant x11-apps x11-common x11-session-utils x11-utils x11-xkb-utils xauth xbitmaps xfburn
xfce4-battery-plugin xfce4-clipman xfce4-clipman-plugin xfce4-cpufreq-plugin xfce4-cpugraph-plugin
xfce4-datetime-plugin xfce4-dict xfce4-diskperf-plugin xfce4-fsguard-plugin xfce4-genmon-plugin xfce4-goodies
xfce4-mailwatch-plugin xfce4-netload-plugin xfce4-notifyd xfce4-panel xfce4-places-plugin xfce4-screenshooter
xfce4-sensors-plugin xfce4-session xfce4-settings xfce4-smartbookmark-plugin xfce4-systemload-plugin
xfce4-taskmanager xfce4-terminal xfce4-timer-plugin xfce4-verve-plugin xfce4-wavelan-plugin xfce4-weather-plugin
xfce4-whiskermenu-plugin xfce4-xkb-plugin xfconf xfdesktop4 xfdesktop4-data xfonts-100dpi xfonts-75dpi
xfonts-encodings xfonts-scalable xfwm4 xkb-data xmltv-util xorg xorg-docs-core xserver-common xserver-xorg
xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-libinput xserver-xorg-video-all
xserver-xorg-video-amdgpu xserver-xorg-video-ati xserver-xorg-video-nouveau xserver-xorg-video-radeon
xserver-xorg-video-vesa xterm xxd xz-utils zlib1g
727 upgraded, 86 newly installed, 56 to remove and 6 not upgraded.

It looks like youā€™ve installed an X11 desktop environment (xfce and other tools). This isnā€™t officially supported.

I suggest reinstalling OSMC.