Upgrading from rasbmc --can not get osmc to boot

I have three rasberry pi2’s I want to upgrade to osmc. first tried NOOB 9.xx only option was debian. after trying to install kodi on top of debian(new to linux-- grew impatient.) I reformatted the sd drive and used osmc installer on win 10 pc to image the sd drive. only boots to rainbow start thens stops. bought some new lexar sd disks same problem. used win32 diskmanger to copy an image to sd but when used with raspberry pi same problem. I tried many different combinations.

zero success rate with osmc. any other suggestions.

Indicates wrong version being used.

  1. Which device have you chosen in the installer?
  2. Post a picture of your device
  3. Plug the SD card back into the windows 10 machine and show the directory listing

You need to pick Pi 1. Raspbmc never ran on Pi 2 / 3, so you must have an original device

1 Like

I have been using raspberry pi 2 b. I also tried it on ras pi 2a. ran installer rasberry pi 1 and it worked.

I guess you have a pi 1 model b+ and a+.
Post a photo of the silkscreen on the board if not sure.

If the Pi 1 installer worked, you have a Pi 1

Thanks for helping me resolve this issue

That’s great :slight_smile: