UPnP/DLNA not working

I wonder if it’s just happening to me, but I have Raspberry PI 2 with OSMC latest update, and Kodi version 15.1.

I go to settings > services > UPnP/DLNA, and enable “Allow remote control via UPnP”.
So then I open up popcorn time on my main linux machine, choose a movie, and Kodi is not listed under available players (If you are not familiar with that program, basically it can stream movies to other dlna-enabled devices). My smart Samsung TV is still listed as well as Panasonic TV, so it’s not an issue with popcorn.
Everything was working as expected on Kodi 14, and I think (but not sure) even on Kodi 15, but when I updated to Kodi 15.1 I started getting this issue.

I can still ssh into Raspberry, and I can connect with Kore remote on my android, so it’s not a network issue.
Also there is no firewall enabled on both my main machine and the Raspberry.

Things I tried already:

  • Just to be sure it’s not a problem with popcorn time, I installed BubbleUPnP on my android, and Kodi was not listed there either. But one weird thing I noticed (workaround?) is that if I recheck that Kodi setting to enable dlna while BubbleUPnP is running, it gets listed and you can stream normally, but if I then reopen BubbleUPnP, its not listed anymore and you have to recheck that option again in order to see Kodi on the list again.
  • running sudo netstat -natp before and after enabling dlna. And I see port 1330 gets opened, so it is running indeed.
  • reformatting my sd card, and fresh installing OSMC, but nope, still the same.
  • installing latest version of KodiBuntu in a VirtualBox on my main machine to see if it is an issue with Kodi or OSMC. And to my surprise, it worked perfectly, it got recognized in both Popcorn time and BubbleUPnP instantly.

Alright, so after full 2 days of screwing with this bug, trying every possible combination of options, rebooting my rpi 100+ times, restarting configs, etc etc… I can proudly say I finally made some progress, and figured out the cause of this problem.

So, I noticed that if I
rm -r .kodi
and restart rpi, then go to settings and check “Allow remote control via UPnP” (because its disabled by default), everything mysteriously works correctly.

So, then I copied back my old .kodi folder back and started deleting files one-by-one, to see when it will stop working again. And sure enough, it was the last thing I could’ve think of. It was the .kodi/userdata/Database folder.

TLDR: If I: rm -r .kodi/userdata/Database/, dlna starts working again as it should.

But, it seems to be only temporarily - after a while (a few hours), it stops working again, and you have to delete Database folder again.

I will try and delete file inside Database folder one by one, to see which file exactly is the problem, and will update you when I have time again to screw with this.


.kodi/userdata/Database/Addons19.db is the one causing problems.

After further investigation, I came to conclusion that Youtube addon (version 5.1.8 from official repository) is causing issues.
More precisely - if you play any video, and later you restart your raspberry pi, Addons19.db somehow gets corrupt and DLNA stops working for some arbitrary reasons.

So the workaround I have so far is to ssh into Pi, and run: rm .kodi/userdata/Database/Addons19.db and then reboot the Pi.

Anyone experiencing the same thing? Can anyone come with a better workaround, or does someone know how to fix this?


Hi svasj

Thank you so much for sharing your research. I had exactly the same problem with an up-to-date OSMC server on a Raspberry Pi 2. This behavior only happened after a controlled reboot. Your fix (remove Addons19.dbdid help!

Unfortunately, I do not have a better workaround.

Good news, I actually completely resolved it since then! I just forgot to update this thread with solution.

Believe it or not, it is the OpenWeatherMap weather addon that is causing problems. To fix, remove that addon, and then remove any leftovers that have to do with that addon from .kodi/addons, .kodi/temp and .kodi/userdata. Lastly remove Addons19.db for the last time, and reboot your Raspberry Pi.
I didn’t have any problems whatsoever, for more than a month.
You can also install Yahoo Weather instead, which works perfectly for me.


Thank you! Strangely enough, I did not have any weather addon installed or activated.

I did install Yahoo Weather, just for fun and removed the leftovers. Let’s see how this will work out.

Thanks again.

Well, in that case, it is very strange that you have the same problem but don’t have OpenWeatherMap installed.
Because you said removing addons database helped, I suspect there may be another addon that causes same issue as well. I recommend removing your installed addons one-by-one until you find the culprit.

Good luck!

Thanks man, I actually had given up on this till today, when google finally gave me this thread!
I’m grateful to be able to stream thinks around again.
have a nice day

I used an older version of OSMC(OSMC_TGT_rbp2_20150628) and it works find just don’t use OSMC_TGT_rbp2_20160118 image.

Please do us the favour and switch to OE.
Otherwise if you are interested in supporting OSMC upgrade to latest version and provide logs and description of your problem

1 Like

Its not exactly my problem. But I increased some of the numbers in bubbleupnp player. In the tweak section…
before that osmc was randomly accepting songs… Sometime it worked then the system stopped for half an hour not playing any song. Raspi 2 fresh install osmc and all updates… I wonder if samba client in the back gets to busy?

Looks to be working again. thanks OSMC team

I still have this issue, - Re-installed OSMC today, did not install any aditional pluins.

After deleting the database folder and rebooting, it worked once, but then stopped working again.

Is there any logs I can contribute to help track the issue?

If Kodi won’t start you can upload logs via SSH with:

grab-logs -A

@DBMandrake, I meant logs to help track why UPnP/DLNA stops working, Kodi itself starts nicely. The logs grabed by “grab-logs -A” don’t seem to be very usefull to that end:


rm -r .kodi/userdata/Database/ still solves the issue temporarily.

EDIT: I guess there where some issues with the context of my shell or something, second grab looks more useful:

It’s temporarily fixed again now - I might need to upload another bug next time I manage to reproduce the issue.

OK, here is the real issue. You or I was not getting a good connection. I have since moved my wireless router closer and all is working peachy.


did you find any permanent solution to this problem?
I am also facing the same issue that after some time the OSMC DLNA server can no longer be found on other devices as a renderer (using Bubble-UPnP on my android phone). I have not tried removing that Addons19.db file. For me it is enough to stop and then restart DLNA server in the OSMC menu. After this I can find the server and I have no idea what can cause it to be undiscovereable again after some time.


Maybe wifi dropped out and kodi stopped doing its multicast stuff ?

I could never get osmc to see my upnp server if it started before wifi came up

I don’t think that is the problem. I am using wired connection on the pi so there should be no drop outs.

this is exactly the same behaviour I see with my raspberrypi 2 as I have described in this thread.