UPnP Library share issue

I’m trying to set up UPnP library share again from my Pi2 to my PiB.

Setting this up via “Title” works for TV Shows but NOT with Movies. Selecting “Title” for the movies it just times out adding the UPnP source. All the other options work ie; genre etc.

Was working fine under Alpha 4 and RC but trying this again with RC2 it doesn’t work.

Log: http://paste.osmc.io/jibopenage


Still no one able to assist please.

I have now enabled UPnP sharing on both Pis.

Attempting to set Videos via Title fails via UPnP on both devices. It seems there is an issue with the implementation of UPnp in RC2.

Setting TV Shows via Title works immediately.

Still no one able to assist please…

13 days without a reply means nobody here knows the answer to your question, so continuing to bump the thread is not going to help and is not good netiquette.

Have you checked over in the Kodi forum at http://forum.kodi.tv/ ?

This type of issue is almost certainly a bug in Kodi itself and not specific to OSMC. Whilst it might have been working in Alpha 4 keep in mind that Alpha 4 was using an earlier version of Kodi, so the bug may have been introduced in a recent update of Kodi, and is probably only an OSMC bug in as much as we now ship a later version of Kodi than we previously did.

You’ll find a lot more people in the Kodi forum and for Kodi specific problems like this you’re likely to get more responses due to the sheer number of users on the that forum.

Thanks DBMandrake. Point taken.

I am over in the Kodi forums now.


They are onto it in the Kodi forums @DBMandrake but it looks like an isolated issue for some reason or most people don’t library share or it is indeed a bug.

I was wondering if there may be some issue with my UPnP xml file or files. Is it possible to remove the xml files and they are then created freshly again on a restart?

Basically what I am trying to achieve is a clean slate with UPnP rather than having to complete two new fresh install.

This is what I am trying to do: http://kodi.wiki/view/HOW-TO:Share_libraries_using_UPnP but, as mentioned, it doesn’t work for sharing via “Title”.

@DBMandrake, in the Kodi forum they advised that my setup is looking for external subtitles via UPnP. They recommended me to turn this setting off.

I can find no references in my searches for such a setting in Kodi 14.2 only for Isengard.

There is definitelty something strange going on. If I use the PiB as the server and Pi2 as the client it works fine. Unfortunately I need the Pi2 to be the server and the PiB to be the client.

Ok, looks like we are getting somewhere.

It seems to be an OSMC specific UPnP issue:

Hopefully resolved in the final build.

We won’t be releasing any further updates of Helix however Isengard is just around the corner and will fix this issue.

Understood - no problem at all. I meant final with Isengard.

Thanks for all the help in resolving this so far.

Hi @sam_nazarko

As per your post in the Kodi forum, will this UPnP issue be fixed in a RC3 update or when you release the final?

There is no rush but I just wanted to check because, if the fix has already been implemented, it (UPnP library sharing) still doesn’t work.

Thank you.

It will be released with Kodi 15.x


1 Like

All working with Kodi Isengard as promised. Thanks @sam_nazarko.