UPnP Server not reliably accessible

I am using a UPnP Server (miniDLNA running on a banana pi) for media streaming over the home network. My computers and tablets can access it very reliable, but my Raspberry Pi, using OMC, cannot. Unreliable means:
When I boot my Pi and navigate to the UPnP source (it doesn’t matter if I want to hear music or watch a movie) there are two possible cases:

  1. I can access the UPnP server without problems. This remains the case as long the Pi is running.
  2. I cannot access the UPnP server (I think the error message is something like »network error, host unreachable«). This remains the case as long the Pi is running. The server is not listed in »UPnP devices«, if I want to add a new media source.

So I can access the media server everytime during a session, or never during a session. If the latter is the case, I have to reboot and hope, that the first case will come.
Case 1 occurs 1 of 10 times, case 2 occurs 9 of 10 times – so if the host is not reachable, I have to reboot many times to »fix« the problem.

The device I am using is a Raspberry Pi 2, having this version of OSMC. Also I am using the DAC+ Sound Card (Standard) from HifiBerry. I successfully installed it using the device overlay option which is provided by OSMC. No extra tinkering, except deactivating GPIO LIRC).

The only attached peripheral is this wi-fi antenna.

This is the first time I am using OSMC, so I can’t say anything abound previous versions.

Here are the logs: http://paste.osmc.io/sasobetibu.vhdl

Kind regards.

Wifi ?

I had this issue and it was driving me nuts.

UNTIL I enabled “wait for network” on the wifi config page.
It needs a reboot after that.

Wi-Fi is not a problem. I can stream from twitch, even if the UPnP server is not accessible.

@RPIer, Please try Penfold42’s suggestion:

I may be wrong, but i think OSMC is checking your media sources on boot, before the wifi connection has been established. On some boots it will connect your wifi quicker than others. If you tick wait for network osmc should check your sources after your wifi is connected. (Can someone please correct me if I’m wrong.)

If you already got wait for network ticked, I would format your sd card and start from scratch. I had a similar problem with one of my Pi’s, not always seeing mysql server, even with wait for network ticked; when I was using wifi. I reinstalled from the latest image and the issue was resolved. (I know your not using mysql, but minidnla instead. But it seems like a similar scenario)

I’m not saying wifi is broken.

Playing over Nfs worked fine for me too when it couldn’t see the upnp servers.

Do you have wait for network ticked ?

in my case, I suspect kodi was starting before the wifi connection had come up and I’m willing to bet that it never did a proper multicast bind to hear the Dona servers announcing themselves.

Without wait for network ticked if I did a “service mediacenter restart” it would work fine.

@penfold42 Thanks for your advice. I ticked that option and rebooted 5 times, and after each one the UPnP-Server was accessible. That workaround helped!