UPnP share is shaky … well not working here

on my 4k (#1) I enabled UPnP. On the same network, in another Kodi (#2) instance I want to connect to osmc (#1). It looks good at first, #2 sees #1 and I can connect #2 to #1 but then it drops the connection. Restarting #1 cures the problem but only briefly.

Do I miss something here?

Thanks

Is the other Kodi instance using OSMC?
What device is it running?

UPNP in Kodi is currently a bit flaky but I believe there are improvements planned for v18.

Some debug logs might help work out what’s happening

the other Kodi is Kodi 17.6 on Linux Mint 18.3… is there a specific log I should look for?

I have been using UPNP Library sharing between RPi’s for over a year (both running OSMC). It’s very stable for me, especially since Kodi 17 I feel it is now mature.
(it’s just not well integrated in skins unfortunately, but you can customise that).

Even newly added content shows quickly on the UPNP client (this used to be an issue).

Perhaps you need to enable UPNP in your router? I did that.

I don’t think it has something to do with the router unless you want to make use of its specific media server (UPnP/DNLA) which I don’t.

Many routers have problems with UPnP (and Avahi), usually between wired and wireless interfaces.

I always thought that was security related; i.e. don’t let broadcast packets from Wireless to Wired etc.

On my old Zyxel router, UPNP Library didn’t work without that checkbox in my router enabled. But that was a very crappy router, perhaps on normal routers you don’t need to enable it.

I’m using an Asus router with advancedtomato. I normally would activate UPnP if I wanted to provide directories from an attached harddrive via UPnP. Since I don’t want this I don’t see much sense in activating it. But I might give it a try you never know :wink:

:+1:

“Normal” Tomato routers don’t have a problem with wireless <-> wired multicast, so I guess you’re going to be ok, too.