Upnp stopped working after July update

When I select my upnp source, I get Cannot connect to server. When I try to add new upnp source, it does not show any. This is happening after I installed July update.
Here is kodi.log with debug info

I can access those sources from other OSMC and other computers.differemce between those OSMCs is that the working one is B+ and failing is rpi2
Any help ?
Thank you

I have both B+ and Pi2 , both with july update, and I’ve added upnp sources since the update and had no problems.
At what stage did you get the problem, and was it the cannot access source type?
I couldn’t see any thing relevant in that log.

Exact error is Cannot connect to network server. It appears when I select my source from Video/Files. And it definitely worked before, used daily.
This is the part in log which appears at that moment

PushCecKeypress - added key b
11:42:53 71.340797 T:1956585472 DEBUG: OnKey: 11 (0x0b) pressed, action is Select
11:42:53 71.343781 T:1956585472 DEBUG: CGUIMediaWindow::GetDirectory (upnp://0011321d-1e28-0011-281e-281e1d321100/55/)
11:42:53 71.344093 T:1956585472 DEBUG: ParentPath = [sources://video/]
11:42:53 71.346199 T:1956585472 ERROR: GetDirectory - Error getting upnp://0011321d-1e28-0011-281e-281e1d321100/55/
11:42:53 71.349281 T:1956585472 ERROR: CGUIMediaWindow::GetDirectory(upnp://0011321d-1e28-0011-281e-281e1d321100/55/) failed
11:42:53 71.349907 T:1956585472 DEBUG: CGUIMediaWindow::GetDirectory (sources://video/)
11:42:53 71.350304 T:1956585472 DEBUG: ParentPath =
11:42:53 71.366974 T:1570493472 NOTICE: Thread BackgroundLoader start, auto delete: false
11:42:53 71.380936 T:1956585472 DEBUG: ------ Window Init (DialogOK.xml) ------
11:42:53 71.381294 T:1956585472 INFO: Loading skin file: DialogOK.xml, load type: KEEP_IN_MEMORY

When I try to add upnp source I don’t see anything new in log, it just does not show any upnp server on the network

Have you tried rebooting your router and your upnp server?

I restarted upnp, did not help. And as I said, other devices on the same wifi can access it without any issue.
Is there anything I can do to diagnose ?
I can access SMB from the same NAS, just upnp stopped working.

I installed OSMC from scratch. In video-files-addsource-browse I can see my upnp server. Then I updated OSMC to 2015-07. Now I cannot see upnp server. No addons, no repositories, just vanilla install + July update.
I really have no idea what to check.
Any help please ?

I just racked my brain on this and stumbled on what looks like a regression.
I did a new setup on a Pi3B after running on a Pi Zero for over a year. I use DLNA all over the place and I don’t accept the “don’t use DLNA” POV. With the OSMC skin on the latest OSMC (downloaded today), I could not add any video sources which were upnp. I tried everything. Add was disabled in the add files window. I switched back to the Confluence skin and then the usual add sub-dialog showed up which allowed selection of server type. I selected upnp and all my servers showed up.

Can you tell us if UPnP works with the Estuary skin?

Specifically, the feature we’re talking about is the default behavior when you navigate to:
Videos | Files | Add videos… | Click “Browse”
In the old default skin (Confluence) and in Estuary, the behavior is to show a pop-up dialog with different file and server types from which you can select UPnP and other types.
In the OSMC skin, clicking Browse sends you to a screen that allows you to type in a search string with some string type helpers on the left of the screen keyboard.
“Add” is disabled.