UPower Issue causing Reboot Loop

Hi All,

I’ve recently installed OSMC RC 3 as a fresh install on my Raspberry Pi 1(512MB). After installing a few background things via SSH (nginx, git) I seem to be caught in a reboot loop - the pi boots up, shows a blue screen with a sad emote and then flashes to black before showing the emote again…seemingly infinitely. I guess OSMC is restarting?

Everything else seems to be working fine, I can pull from my git repositories fine and my nginx server is running consistently.

Looking in kodi.log, the only error I can see is this:

ERROR: DBus: Error org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.UPower was not provided by any .service files

I’ve tried running sudo apt-get update && sudo apt-get -f dist-upgrade but I’m still getting the same error.

I suspect something strange is going on with DBus? so I ran ls /usr/share/dbus-1/services:


and ls /usr/share/dbus-1/system-services/:


Have I lost UPower? Any help would be greatly appreciated, I feel like I’m getting a tad out of my depth with this one.

sudo journalctl | paste-log output:

Seems like a lot of issues with things being marked as executable? Not sure why.

No that’s not OSMC restarting, that will be Kodi crashing - when it does, the sad face is displayed by the watchdog script which will restart Kodi again after 10 seconds unless you press the ESC key to log in at a local console.

You can stop worrying about UPower - that error message is normal as we don’t use UPower on OSMC and UPower is just one of many different ways that Kodi can control the system power. (EG initiating reboot/shutdown and so on)

Looking at your log file it would be helpful to know exactly what you installed, and what was the last thing you installed before you had this problem, because it appears that you have some really screwed up file system permissions…

The reason Kodi is crashing is because of:

Jul 02 09:19:15 osmc mediacenter[267]: *** Error in `/usr/lib/kodi/kodi.bin': double free or corruption (!prev): 0x030863b8 ***
Jul 02 09:19:15 osmc mediacenter[267]: * failed to open vchiq instance

This is probably happening because the file /etc/udev/rules.d/999-fix-vchiq.rules is corrupt or missing. Without this Kodi can’t open the vchiq device and will crash. Can you check this file and see that it has the following ?

# vchiq
SUBSYSTEM=="vchiq",  GROUP="video", MODE="0660"
# sharedmem
SUBSYSTEM=="vcsm",   GROUP="video", MODE="0660"

Another problem I see is hundreds of lines like this complaining about the file permissions on systemd service files:

Jul 02 09:19:00 osmc systemd[1]: Configuration file /lib/systemd/system/systemd-shutdownd.service is marked executable. Please remove executable permission bits. Proceeding anyway.
Jul 02 09:19:00 osmc systemd[1]: Configuration file /lib/systemd/system/plymouth-log.service is marked executable. Please remove executable permission bits. Proceeding anyway.

This is highly unusual - it’s almost as if someone has gone chmod -R +x /lib - I can’t see any way that this could happen by accident, and it makes me wonder what else is wrong on the system. Something that you have installed has really screwed around with the system.

For the vchiq problem you could try to reinstall the package that the file belongs to like this:

sudo apt-get update && sudo apt-get install rbp-userland-osmc --reinstall

However I suspect you’re going to have to start over and retrace your steps carefully to see what thing that you installed screwed things up…also you’re best off starting with the final release now instead of RC3.

Thanks for your reply DBMandrake, I tried your vchiq suggestion but to no avail. I imagine another error further into boot has been caused by the strange permissions situation.

I must admit I was experimenting with some shell scripting a while back to speed up installing nginx but I don’t remember being …foolhardy enough to declare the whole lib directory as executable. I’ll do a fresh install of the final release when I get home tonight and report back but I think we can probably chalk this one up as user error.

A fresh install did the trick, thanks again DBMandrake!

Sorry for the bump but I think it’s worth mentioning that I ran in to this issue and the root cause was removing osmc user from the video group, which I did by accident.

I am now wondering what other groups I removed osmc user from (basically missed the -a flag on a usermod -G command). Could anybody check it for me? Thanks!

On a fresh install, here is what groups the osmc user is in:

osmc@dalek:~$ id -a
uid=1000(osmc) gid=1000(osmc) groups=1000(osmc),4(adm),6(disk),7(lp),20(dialout),24(cdrom),29(audio),44(video)