USB 3 Hard drive not recognised

Apologies if this has been answered elsewhere. I searched but couldn’t find a solution.
I have a Raspberry PI3, running OSMC and am trying to attach a Seagate 5TB USB 3 drive.
The drive is formatted ntfs.
It is recognised without problems under Windows 10 and Win7.
I’ve run diagnostics on the drive itself, which is less than 2 months old, and it is healthy.
However, it doesn’t appear on OSMC.
It isn’t automounted to media

blkid gives me
/dev/mmcblk0p1: LABEL=“RECOVERY” UUID=“3566-6232” TYPE=“vfat” PARTUUID=“0008487d-01”
/dev/mmcblk0p5: LABEL=“SETTINGS” UUID=“d0c05c66-e637-48aa-a79a-a77fbcf8571b” TYPE=“ext4” PARTUUID=“0008487d-05”
/dev/mmcblk0p6: LABEL=“boot-rbp2” UUID=“2DDB-B011” TYPE=“vfat” PARTUUID=“0008487d-06”
/dev/mmcblk0p7: LABEL=“root-rbp2” UUID=“10624df2-07d9-4d15-b1a2-c579515223c1” TYPE=“ext4” PARTUUID=“0008487d-07”
/dev/mmcblk0: PTUUID=“0008487d” PTTYPE=“dos”

fdisk -l only lists the SD boot card

The issue has been causing me some frustration!

I uploaded the full debug logs to

I’m not familiar with Linux but have a good technical background.
thanks in anticipation

You probably need to externally power it, or use a better power supply.

I forgot to add, it’s an externally powered drive

in config.txt

Not needed for Pi 3.

I’ve got a pi3, and my drive doesn’t power up cleanly without it - unless it’s a fairly recent change.

Pi 3 doesn’t have a switch for USB current so it will always be 1.2A. It’s not a software change, my understanding is this is a hardware change.

I’ve tried a few more things.

The drive doesn’t appear if I try lsusb and I can’t see any errors flagged using dmesg or anything particularly untoward.

I’ll try setting max_usb_current=1 (probably tomorrow, kit packed away for tonight)
I did try taking the drive out of the enclosure and putting it into a thrid-party enclosure. However the drive wouldn’t power up and on other forums I’ve seen speculation that Seagate have prevented this particular HDD being used outside of their enclosure. It appears possible because a large percentage of HDD parameters (firmware) are 'gray’d out, which is unusual given the drive tools that I use.

So, it was only on the RPi3 I’d be tempted to say a hardware or build error on the Pi. However, smaller drives (1TB) do work on the RPi3 and the drive is recognised in windows.

I’ve tried three different USB 3 cables. I’ve verified as working, each of the USB3 drive cable with a different drive but connecting to the same USB 3 port on the PC in question.
AFAIK the drive is not being recognised by OSMC

Just in case it helps -
I have a couple of usb enclosures, containing HDDs, which have ceased to be recogbised by my pi/vero systems, but which can still be used with Win7 PC.
I’m still not sure what makes the difference.

Many thanks to those who replied.
Unfortunately, my wife decided to tidy & clean where I had the drive, Pi etc. set up and accidently knocked a heavy ornament off the shelf above the drive. So the drive is now history :frowning:
I have a secure back-up so its ‘only’ the loss of the drive…
Roll on Amazon Prime day on the 12th where I’ll buy a replacement drive and start again.

Was the ornament OK? Lol :joy:

Good you had a backup. I remember those gut wrenching moments when hard drives fail without backup.

It was a brass memorial plaque from WW I. So, yes it came off rather better than the drive.
Some years ago I lost a 1TB drive that had several years of photos. Learned the lesson the hard, painful way and now photos, videos, etc and important docs are backed up to a RAID server and the really important ones to the Cloud.

Sweet, we don’t have to fix any OSMC bugs now :wink:

Seriously though – let us know if issue persists with the next drive.