Usb 3 randomly mounting and unmounting

I have recently updated to osmc rc2 from raspbmc in the hope of resolving a continuing issue. Firstly specs, rpi model B, 4 Port usb2 powered hub, usb3 1tb hdd using a single lead (dont have a usb3 y lead) boots from sd and media is stored on the usb. OK my issue is just linked to my usb3 drive as my usb2 works fine. The issue is although my media plays fine and all is well in my pi’s world, if I navigate out of my hdd to the adding or settings page for example my hdd starts unmounting then a few seconds later it will display mounting hdd. This issue keeps happening. When I navigate back into my hdd it stops and works as normal. I thought it mite be a power issue being only a single lead but wouldn’t that affect it outright and not just while not browsing the drive? The hdd spins up and down as it normally does and there is no apparent link between that and the issues I’m having as far as I can tell. I hope someone can help me here as it’s driving me crazy now. I don’t wanna buy a usb3 powered hub if it’s a simple settings change that’s required. If you need a debug log then can you tell me how I can do that as iv never needed to send one before. Thanks in advance

This behavior is typical of failing to provide sufficient power to the drive.

I thought about the power issue and I would suspect it more if it was a constant issue when the hdd is being accessed aswell as not but this only happens when I’m not accessing it. I could browse the hdd finding a film for example and it will work flawlessly but if I go to a add on or the settings page or anything that doesn’t even require a hdd it starts acting up. I just cant understand why it only happens then instead of happening while in use. Would my only course of action be either buy a usb3 hub or switch to a usb2 device or is there anything I can do with regards to settings?

Upload your debug logs so we can see the system journal, this may show a bit more.

It’s still almost certainly power related though - have you tried measuring the voltage across TP1-TP2 on your Pi when you see the problem ? If it’s below 4.75v the problem is power related.

Keep in mind that the power drawn by the CPU varies greatly depending on the CPU usage, especially when overclocked. This means when the CPU is busy the voltage will tend to drop more than when it’s idle.

Some activities, like displaying scrolling text use a lot of CPU, so the problem is probably triggered when certain activities are carried out by the CPU.

Try logging in with SSH and running the following command to make the CPU busy, see if this causes your drive to disconnect:

while true; do true; done

(Press Ctrl-C to cancel it)

Could you tell me how to see what the voltages are and how to create the debug logs. Sorry not needed to do them before. Also FYI it hasn’t been overclocked, it’s just a standard setup using a rpi 512mb. I will try your suggestion though when I get a moment and update ya.

Testing Voltage : Raspberry Pi - How to check your power supplys voltage - YouTube

Logs (from our own wiki page) : https://osmc.tv/help/wiki/logs

hi guys. ok so iv tried performing an upload of my log files from within osmc which is proving a nightmare given the issues im suffering with. so could you just tell me the command i need to type within my ssl client to save the log to my pc for uploading. im pretty much a complete noob with the linux console. FYI i ran the command you gave me to try and that caused my CPU usage to shoot up but never caused my HDD to unmount. with regards to testing the voltage i can do that but need to remove it from its case first. i wanted to try and save the logs before i done that. the log location should be the same as i have a completely new, standard setup if that makes any difference. i just need the exact command to type. thanks in advance

ok i think iv found out how to do it. this is the link i was given

http://paste.osmc.io/jafucecapo

i hope it helps

EDIT: the first instance of the error occurring that i can tell is on line 2230. im not sure wot else i should be looking for. regarding all the keys presses i had to make the issue happen then put a video on to settle the pi to get the log file. wierd i no lol. thanks in advance

Iv tested the voltage as was mentioned and I was receiving a reading around 3.9 i no the range should be around 5. I’m in the process of eliminating possible causes and I no my sd card was causing a bit of a problem with the power but now im thinking it’s my board. I’m currently trying a firmware update to see if that could help. Update to follow

No firmware update will resolve a power issue. OSMC ships with it’s intended firmware, changing this may quite possibly cause other system problems and will not be supported.

My suspicion is that you are attempting to power the pi from your USB hub? This is never really a recommended configuration.

Well the firmware was the latest non the less and it’s not powered by the hub. It’s poweredfrom a dedicated plug outputting sufficient voltage. The powered hub only powers the external accessories, hdd, remote and WiFi adapter. Even after unplugging the hub completely I still suffered a low voltage running through the pi as mentioned in my previous post hence I thought it might of been my sd card as it’s cheap and slow. In a bit ill be removing everything (no sd, no usb, no hdmi) to see if it is infact just an issue with my board as I might need a new one. Update to follow.

OK it must be my card. Upon trying just my pi, then with just hdmi, then with just my usb hub, then just hdmi and hub it all read 4.9 but with any configuration that has my sd card inserted it drops. Sd on its own dropped to 4.3 as it did wen sd and hdmi was plugged in. Sd with usb tho dropped to 4.1 As I think it must be my card I’ll try and find a new decent one and test it another time. If you guys think it might be another issue then let me no. With regards to the power supply I really don’t think that’s the problem, the specs are: dual usb UK 3 pin plug. Model N13KG, output 2x5v 1.05a for 2 usb’s or 5v 2.1a for 1 usb. I’m only using 1 of them usb’s so it’s producing enough for the pi. Please correct me if I’m wrong.

It’s most likely the input polyfuse and NOT your SD card. With the card out the Pi doesn’t boot and therefore doesn’t load the power circuit so you see higher voltage, check the volt drop across the polyfuse, you can jump the fuse or replace it. If you jump it then an external fuse on the power supply is recommended

Sorry, but there is nothing that could be wrong with the SD card that will cause the voltage to drop so low. The problem is clearly your power adaptor or cable.

The reason why the voltage is higher when the SD card is removed is because with the boot drive missing the CPU does not start up - therefore the CPU draws very little power. When you insert the SD card the CPU is able to boot up and start using more power during normal operation, thus the voltage drops.

The fact that it’s dropping as low as 4.1 volts shows that the adaptor or cable is very inadequate regardless of what specs might be claimed for it. Anything less than 4.75 volts under worst case conditions is unacceptable. Unfortunately this is a very common problem - more often than not micro USB chargers/power adaptors do not live up to their claims.

If you are able to get your hands on one of these I highly recommend it after having bought one for my Pi 2 after problems with other adaptors:

http://swag.raspberrypi.org/products/raspberry-pi-universal-power-supply

I’d be surprised if this doesn’t fix your problem.

Dbmandrake : Just ordered that charger so I’ll give it a try once I receive it and update here.

Dilligaf : tbh I don’t even no what that is let alone what to do with it. If you cud point me in the right direction I could check it out but waiting for a new charger to test first.

Thanks for pointing out the fact of it not being my sd card aswel :smile: