USB audio crackle and pop

Hi guys,

I’m LOVING the Vero 4k for its speed, stability and ease of use. I am however having ongoing issues with USB audio, as I am using the Audiophilleo2 to improve audio quality. The problem I am having is that when I start a video/audio, skip forward within it or change to next track, there is often a large short sharp crackle or POP, which is very disconcerting and annoying. It’s gotten to a point where I’m scared to start a video/song or skip forward, and find myself turning down the volume before doing so which is incredibly annoying.

I’ve done searching over the internet and tried multiple solutions. My USB audio device is the default device in ALSA. I’ve tried every combination of ‘keep audio device alive’ and related setting in OSMC. For reference, I did not have a problem with my prior 8 year old small-factor HTPC based on ubuntu.

Networking: Wifi 5ghz (wired ethernet not an option)

Any help would be so greatly appreciated!

Tonight I was trying to get my USB DAC working on vero. I thought I had it working before but today it’s not playing. When/if I do I’ll look into this.

FWIW I’ve just been A/B-ing the analogue out through my old stereo amp and it’s noticeably better than a Yamaha AVR feeding the same speakers.

Can you swap the USB port the DAC is connected to and remark if there’s an improvement?

I have a patch for USB DACs that might be beneficial @grahamh. Will discuss tomorrow in Slack.

Hi Sam,

Yes I’ve tried switching the USB ports previously, unfortunately to no effect. Please let me know if there’s anything else you’d like me to try.

Just wanted to mention that this issue is still ongoing for me.

Anyone else using USB audio having crackles/pops when changing source, skipping forward/backward etc?

I can’t reproduce this. If you post debug logs we may be able to spot something.

Do you find the sound from the Audiphilleo noticeably better than from vero’s S/PDIF, BTW?

Unless they’re outputting different signals then the audio should be identical? But this is getting into audiophile nonsense territory so I’ll stay away :rofl:

Can we see some logs when you experience these issues? The kernel message log may give us some clues.

Hi everyone,

Sorry for the late reply. I’ve recorded a video demonstrating the problem. It happens in this video when I skip forward, but not every time. It’s most pronounced when the audio lags a bit, leading me to believe its a possible buffer problem?



In terms of improvement of sound quality, I couldn’t tel you how it differs from the OSMC optical output, because I’ve never used it. It was an improvement over my previous HTPC setup though.

Thanks guys.

I’m afraid we can’t do much with that log unless you turn on debug logging.

It’s a bit more than a crackle, isn’t it?

To narrow it down, and if your DAC has an optical input, could you try that direct from Vero?

Apologies, here’s another log. I’ve did similar steps as in the video and reproduced the pops.

You’re right they do vary in loudness but they can get very loud, which is disconcerting. My fiance hates it.

I don’t have a optical cable on me but I’ll try to do that when I can.


Thanks. For HDMI we take care to mute audio while things are changing. Maybe that isn’t happening with USB. I’ll try again to reproduce this with my entry-level USB soundcard.

Any progress on this guys? I’m still having the problem.

I think the issue may be specific to your USB audio device.


sry too little spare time.