USB Audio to Arcam DAC

Hi there,

I’m still pretty new to OSMC (a poor start to any request) but was hoping someone might be able to point me in the right direction with USB Audio.

I’m running the below setup:
-Raspberry pi 2
-Arcam rDAC (usb)
-OSMC 2015.06.01-1

In the Audio Output menu ‘Alsa Arcam DAC’ appears as an option (spdif and analogue) however it doesn’t seem to work if i select it.

If selected music and videos on OSMC won’t play, music stays at 0:00 while videos stutter heavily and don’t play any sound. I do get a click sound however going through the menus.

Does anyone have any suggestions for settings, files etc that I could try changing? I’d love to get this working through my hifi : )



I have the same problem with my Arcam irDAC.
I get no sound from the usb audio after choosing the “Alsa Arcam DAC” from the audio output.

I`ve change the usb to 1.0, enable turbo mode, and nothind worked. Also installed pulsaudio (and selected pulsaudio in the audio output), which worked only in the first time. After rebboting the system i again got no sound.

I don`t know what to try more to resolve the problem…can anyone help?

I`ve update my raspberry 2 with the lasted version of osmc.

Many thanks

Try setting the resampling away from Gpu accelerated to low quality, then stop and play the music again. if that works it seems like you have the same issue that i did with my NAD usb DAC. My complete fix is External USB audio, hiss and clicking sound - #16 by Maz with external links and stuff.
Good luck.