USB drive no longer shows up

So this issue affects my Pi running OSMC but is also affecting my Chromebox running Libreelec as well. I got a 6TB WD MyBook HD to expand media storage and it worked slick. I plugged it into my Chromebox and located the files under the root/media folder and added the sources and it worked fine. I could access them over my network from my MacBook. Then one day, my daughter tries to watch a movie and it can’t be found. The drive and all it’s contents vanished from the root/media files even though the drive is plugged in via USB and turned on. I tried plugging it into my Pi running OSMC and it was the same result. It just wouldn’t show up. I plugged it into my laptop and it works fine and all the files are there. I moved a ton of media over to this thing and I’m really at a loss.

Which filesystem are you using? Have you run a checkdisk on it and ensured clean eject before disconnect?
Suggest to upload logs so that we might see what the problem is.

Never done a check disc before. I’ll have to try that. The drive itself is formatted exFAT. I never disconnected it before I started having the problem, but yes, if there’s an option to unmount it first before unplugging I always do that. I’ll have to figure out the log thing because I have a closed system not connected to the internet.

grab-logs -C -A will write it to /boot from where you can transfer to your PC and upload to