Usb drives not recognised

Hi. Did a fresh install of kodi 17 on vero 4k. None of my usb drives, which are plugged into to the osmc usb hub, are recognised now. Tried rebooting, switching switches on/off on the hub etc. Nothing recognised at all.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Ok. First time I’ve done this. Hope this is correct.

Usb drives work no problem plugged directly into vero 4k by the way, and haven’t experienced this issue with the hub since receiving it a few months ago until now. Thanks.

Can you show how you’ve connected your hub with a photo?
Can you try the hub on a PC?


Hey Sam. Vero is tucked away in the upper cabinet, but here are some pictures of the hub. Also tested on my Mac…both usb drives were recognised, but took a good few minutes to recognise them. Thanks

Thanks. Looks normal.

Why is it taking so long for your computer to find the drives? Did you use the hub on the Mac?

Does plugging in one at a time make any difference?


Yeah sorry should’ve been clearer- I used the hub on the Mac. Just tried this again on my Mac and both drives are recognised pretty much straight away now via the hub when either both plugged in together, or one at a time.
I’ve just retested on vero 4k using above methods but none of the usb drives are recognised still. Strangely however, I now notice that a slight movement of the hub turns its power on and off (red light goes on and off, and can hear usb drives starting up and shutting down) which seems related to the power lead connnection to hub.

It’s worth saying that power to the hub has definelty been on and uninterrupted while I’ve been trying to get the vero to recognise these usb drives.

Tee. Are your drives HFS+ format? Just curious. My new Vero won’t recognize a HFS+ drive plugged into Vero USB port.

Working on that :slight_smile:

Both of my drives are formatted exfat and are recognised by vero if plugged directly into it, just seem to be having problems via the osmc usb hub.


Could you clarify if attaching a single drive is successful>
if you turn off power to each disk, does this change anything?

It’s probably best we swap the unit out for you if you have cable problems


Just to be sure you can shutdown your Vero and only remove the blue USB cable from the switch, so only the power supply and the disks are connected.
Recheck the hub’s power supply is seated correctly in the plug socket.
Then start your “movement” action again and see whether the hub’s blue and red LEDs glow permanently or not. With that you should see whether there is a potential cable break.

Unfortunately the red LED is always on regardless the hub gets its power from the USB downstream port of the Vero or its own power supply. So, the red LED is not an indicator for a correct working power supply when the hub is connected to the host system the same time.

Appreciate the support guys- will test when back from work.

Ok. So tried this again. Attaching a single drive wasn’t successful. Turning power off on the disk did nothing either. Swapped the USB port on vero that hub is plugged in to- nothing changed. Swapped USB port back, and the screen seemed to refresh itself briefly. I then also noticed that the red light on the hub wasn’t turning on and off with movement as it was previously. Then both usb drives were recognised. I’m confused.

Can you post a log when things are detected and when they aren’t?


Hi Sam. Unfortunately this time no matter what combination of things I try, I can’t get the vero to recognise any of the usb drives. Tried switching hub on and off whilst connected to vero, switching USB ports on vero, but no joy.

I’d suggest we get you a replacement hub.
Please contact so we can arrange this for you.

Will do Sam. Appreciate the excellent customer support.

As per our emails, a replacement hub was shipped for you today. Let me know how you get on.