Usb dvd player, no image; Vero 4k

My setup is: Vero4K, updated to the December release; dvd-player connected to usb-port, a beamer connected through HDMI to project the movie I want to play on a screen.

I have been able to play dvd’s in this way, without problem.
This is the first time I try to play one since the upgrade to the December release.


When I start play of the dvd the intro (announcing that it is a BBC DVD) is played, with sound. Once the intro has ended the screen goes black, the sound keeps playing.

Whenever I use the remote to switch back to the OSMC-menu the beamer reports that OSMC is switching to another resolution and playing of the DVD seems to stop momentarily. (This switching also happens when I am playing youtube, and switch from the movie to the OSMC menu.)

The DVD I have tried to play has these properties on its casing ASPECT RATIO 4:3, MAIN SOUND TRACK: MONO, ENGLISH; DISC FORMAT DVD9, FEATURE LENGTH: 157 mins*, REGION: 2 + 4 PAL UK, SUBTITLES: English for the hard of hearing.

I also tried another DVD**. I am afraid I can’t find all the properties, but 93 mins, DVD 9, 16/9 anamorphic, Dolby 5.1, Dolby 2.0; This DVD won’t play at all. Not even sound. It simply does not start.

  • Shakespeare, the Merchant of Venice :wink:
    ** Pianomania

Any advice on what I may be doing wrong?
Is there any more information I can provide?

Edit: perhaps I should add that when I wanted to play the dvd first time since the december update, the Vero 4k did not show the menu item “play disc”. Only after rebooting several times that menu item was shown.

How is the dvd player powered?

Through USB (it only has one cable), connected directly to the Vero4k-USB-port.

Do you have a powered USB hub to test with?

No, sorry; this setup worked perfectly until before the December-update so I never felt the need to buy a powered USB hub.

I am not an expert at all, but I just had a glance at the logs (I am eager to learn). I found something which to a none-expert like me seems to be perhaps related:

16:18:19.953 T:4080173648  NOTICE: VideoPlayer: finished waiting
16:18:19.954 T:4080173648  NOTICE: VideoPlayer: Opening: /media/THEMERCHANTOFVENICE/VIDEO_TS/VIDEO_TS.IFO
16:18:19.954 T:3488576256  NOTICE: Creating InputStream
16:18:19.988 T:3488576256  NOTICE: VideoPlayer: playing a file with menu's
16:18:19.988 T:3488576256  NOTICE: Creating Demuxer
16:18:19.993 T:3488576256 WARNING: could not find codec parameters for /media/THEMERCHANTOFVENICE/VIDEO_TS/VIDEO_TS.IFO

Hmm, I may have misled you: so far I had used this DVD-player on my rapsberrypi, running OSMC. I then bought the Vero4k, and put the rapsberrypi away, and may not have used the DVD-player since then (I am not sure, though).

Still, to test, I connected the DVD-player to the “old” raspberrypi and rebooted. It has the menu item “play disc” and does play the “pianomania” DVD without problem.
Is it useful if I were to upload the logs of the rapsberry as well?

I now also tried the Merchant of Venice DVD. Also works.
Logs here:

The “could not find codec paramaters” appear in this log as well, so I stand corrected, and this message is perhaps not relevant:

17:24:17.110 T:1421030144 WARNING: could not find codec parameters for /media/PIANOMANIA/VIDEO_TS/VIDEO_TS.IFO
17:24:17.111 T:1421030144 WARNING: CDVDInputStreamNavigator::GetVideoResolution - Failed to get resolution ()


17:32:13.550 T:1421030144 WARNING: could not find codec parameters for /media/THEMERCHANTOFVENICE/VIDEO_TS/VIDEO_TS.IFO
17:32:13.550 T:1421030144 WARNING: CDVDInputStreamNavigator::GetVideoResolution - Failed to get resolution ()

Is the Pi running the same version of OSMC?

Feature titles should play fine, but menus can sometimes be problematic.

Vero and pi are running the same version of OSMC.

Both DVD’s play well on the pi, feature titles as well as the main movies, but they won’t play on the Vero.

When I checked the Vero for updates, it stated there were none.

Any suggestions as to what would be a next step to investigate or solve?

There might be some things we can do. The feature should definitely play. Only menus should be a real problem.
Check PM


I’ve been using a DVD player for some time now, although a powered one. Only a couple of specific movies don’t play properly, the others are fine.

28 posts were split to a new topic: Testing USB/IP