USB external drive mounted as a read-only filesystem

I physically disconnected a USB external drive from the OSMC, and then connected it to Windows 11, to transfer some files.

Something changed. I have reconnected it to OSMC, and am now seeing this behaviour:

osmc@osmc:/media$ touch /media/Elements
touch: setting times of ‘/media/Elements’: Read-only file system

The drive appears to be mounted as a read-only filesystem. It should allow full control.

I’m not very experienced with Linux, and don’t know what to do.

How is the drive formatted?

Windows says it’s NTFS

(It’s mapped over network)

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Before unplugging the drive did you either, power off the device, go to videos>files> highlight “Elements” then context menu>safely remove, or via ssh umount /media/Elements? If you restart the device is it still mounted as read only?

If I’m reading it correctly the system is telling it to mount as read/write but the drive is set as read only. Can you write to it when it it plugged into a PC? Searching the internet finds that as external WD drive getting set as read only out of the blue isn’t an unheard of problem. If this is what is going on then you could try [this].

Yes it still works normally when I reconnect it to the Windows 11 PC.

Well, low hanging fruit could be to

  1. connect the WD Elements to your WIndows PC
  2. check the file system (on Windows 10 right click on the volume in an explorer window → properties → tools → check → scan anyway)
  3. safely(!) remove the device
  4. reconnect it again to Vero

Let us know what happens then.
BTW: I assume this is a self-powered hub you connect your Logitech Gamepad, the Seagate and the WD hhds, right?

IIRC, I had to change a setting in Windows 11 that was making the drive work like a system drive, not a USB device. The Safely remove hardware option wasn’t available previously, so when it was time to disconnect the device, I just unplugged it. Maybe I should have unplugged the USB before power. Anyway, Safely remove hardware is now available, and I connected the drive to Win 11 PC again, used the manufacturer’s tool to run a full scan (which took a whole day) and ejected the device safely. I connected it to OSMC again, and have not had the issue since.

Happy to report issue resolved.

(HDDs are both self-powered. HDDs and gamepad all three use the USB ports on device, Raspberry pi 3 v2.)

1 Like