USB HDD automounting with duplicate names

I’m helping a friend with his Vero4k+ that suddenly developed an issue with its media sources. Everything is stored on an 8TB Seagate USB-disk and the setup has worked well for 6+ months. When I now looked at it, I found the following duplicate entries automounted:


The first entry is the original and proper one used by all media library sources. The last of the duplicates is the only one currently corresponding to the actual disk.

I’ve checked the disk for errors but it’s fine.

Any ideas?

Posting some logs should let us see the mounts

I suspect the disk hasn’t been unmounted properly a number of times, leaving empty directories in /media/.

Check out what’s in /media/Seagate8TB etc to confirm. You probably just need:

sudo systemctl stop mediacenter
sudo umount /media/Seagate8TB*

Unplug the disk and check all those directories are indeed empty, then.

sudo rm -r /media/Seagate8TB*

Plug in the disk and re-boot.
Tell your friend to make sure to shut down the Vero from the GUI whan they want to turn it off.


Thanks! I’ll try that. I also suspected it to be due to unclean shutdown but he claims not. It might be the girlfriend. Or the cat.

I’d also suggest checking the USB cable of the drive. If a drive disconnects and reconnects quickly, it can do this.

You could create a fstab entry to force the drive to always mount in the same directory.

There is code (or used to be) to automatically delete left over mount points in /media on a reboot, so a reboot should have fixed this, no need to manually delete the mount points.

As to the original cause - most likely the drive has been unplugged without properly unmounting it and then quickly reconnected.

This could be the user doing this or might be a result of a lack of USB power causing the drive to repeatedly drop its connection and reconnect. If it keeps happening when it is not being deliberately unplugged I would check the power situation with the drive and the cabling.

He has a remote power on/off switch and confessed that he might have forgotten to shut down his Vero properly a few times before turning off power. Deleting the old mount points fixed it. Thanks!