USB key content not listed when using UPNP


I have setup OSMC on a raspberry pi 3. I have enabled DLNA support to be able to stream to my ipad. If I plug a USB stick, I can play each file within OSMC, I even have a shortcut that appears with the name of the USB. Now, If I access this content via the DLNA client (VLC on iPhone), I do see my server, with 2 folders (video etc), I can go into video and see my USB key but when I click on the usb key, I have nothing listed.

So, on OSMC, I try now to add a new source and chose system folder, I can go where my usb is mounted and add its content. I now have in OSMC 2 identical folders with the name of my USB key. If I access the server via UPNP, I now see 2 folders for my USB key, one has all the files and can be streamed, the other is empty.

I find this a bit strange that the USB key is not being able to be listed within DLNA automatically. Am I missing a step somewhere can this be a bug ? I have tried the same thing on Raspbian with the supported version of kodi and it is the same. I have tried to also add content on the USB key, update library, but nothing helps.

Any help on this would be appreciated…


Issues with DLNA behavior should be directed to Kodi.

Could it be that the second folder has music?
Read up here

Actually, these 2 additional folders are under video and have the same name as my USB key

OK, I posted my question on Kodi/raspberry forum. Hopefully I’ll get an answer or directions.