USB Sound Issues

Hi all !

I have been running OSMC on my RPI2 for a while and it works great. However i have a weird sound issue where occasionally the usb sound card sink gets unresponsive. Only remedy is to reboot the Pi which is rather annoying.

This is what i see in the log:

This happens rarely but i can trigger it reliably by playing several movies consecutively in a playlist.

11:44:50.423 T:1387262960 NOTICE: Creating audio stream (codec id: 86018, channels: 2, sample rate: 48000, no pass-through)
11:44:52.913 T:1387262960 ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer
11:45:00.925 T:1917842416 ERROR: Previous line repeats 3 times.
11:45:00.925 T:1917842416 ERROR: CAESinkALSA - snd_pcm_writei(-5) Input/output error - trying to recover
11:45:00.925 T:1917842416 ERROR: CAESinkALSA::HandleError(snd_pcm_writei(1)) - snd_pcm_writei returned -5 (Input/output error)
11:45:00.961 T:1387262960 ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer
11:45:20.924 T:1917842416 ERROR: Previous line repeats 9 times.

More Log lines here: http://pastebin.com/uXhG7XsX
Head of Log here: http://pastebin.com/91AQRRUp

As you can see it played two file fine then choked.
The error is not specific to the files, they play fine another time.

I have already tried two different USB soundcards:
Bus 001 Device 006: ID 0d8c:013c C-Media Electronics, Inc. CM108 Audio Controller
Bus 001 Device 004: ID 0d8c:000e C-Media Electronics, Inc. Audio Adapter (Planet UP-100, Genius G-Talk)

I also tried to disable omxplayer or mmal in settings, to no avail.

Any Idea what to do ?
Cheers,
Karl

If you can repeat this again and again by simply using it for a long time without a break that would suggest that it the sound card is possibly overheating.

A full debug log may help.

You can learn more about how to submit a useful support request here.

Also check your powersupply.

It works fine for many hours of movies.
It seems to happen mostly when i play movies in quick succession, like in a playlist.

You can see in the log that it happens in the first second of the movie.

I have the feeling that something is not yet fully finished when kodi already starts the next movie, like a race condition.

I have already experimented with different power supplies to no avail. Currently the powersupply is an original raspberry pi power supply.