USB stick works but not when booting

Hello, I am new to OSMC.

I want to build a digital photo frame that auto plays images from a USB stick.

My hardware is a Rasperry Pi Zero W with a USB HUB HAT from Waveshare.
(on OSCM it says Hardware BCM2835)
I run a KODI 18.3 (Kernel: Linux 4.14.78-4-osmc) - installed some weeks ago on a 16GB mirco-SD-Card - all flawless.

When I boot with a mouse at the USB HAT all is fine (mouse recognized properly).
When I plug a usb stick (system is on) (Verbatim Store n Go V3 MAX 128GB USB 3.0) the stick is being recognized and I can browse photos, etc.

However when I boot with the usb stick plugged it, it is not mounted when I am booting. I cannot see the stick at all (unplug and plug back solves the issue).
It does not like insufficient power to me (I use a 2A Huawei mobile phone charger and also supplying the USB HAT with additional power via micro USB does not help anything).

Now since I want the photo frame to run at my mother in law’s house the requirement is that the stick is recognized during booting (and also the photos start automatically, but that’s another question, probably there is some script for that - I will search for that as soon at the hardware issue is solved).

What can I do to have the USB stick mounted when after rebooting?

Thank you very much in advance for your response.

BR, Manaquiri

Phone charger is not a proper power supply, it could be that during booting not enough power is provided and therefore the stick is not mounted.

And just as a side note, as it has been mentioned very often on this forum. There are much better options than OSMC to create a photo frame

Thank you for your feedback.
I’ve tried several other power sources and also another usb stick: no change.

What other systems are recommended for a simple photo frame? I’m looking around but it’s not obvious to me. Thanks for any hints.


Basically just use Raspbian and then any software to show a slideshow there are many suggested by different people who have done it.