USB WD Drive making a chirping noise on Vero 4K+

I have been using this 2TB WD My Passport drive on the Vero 4K for about a year and about 2months ago it began to make a chirping noise in about 4 to 6 second intervals.
It often will not show up in file manager on a restart and it will take one or two reboots until it shows in the files. When this happens a check and repair process in win 10 will get it back to normal.
I suspect the drive might be failing but I ran it with my Windows 10 and my Apple-TV and it is playing normally and is not making the noises.
I am wondering if there is anything in the Vero settings to try before I replace the drive.

Are you directly connecting it to the Vero or using a powered Hub?
I would assume that you have a power issue for the drive.

1 Like

Could be, as fzinken said, a power issue such that insufficient power is making the drive get corrupted. I could also be the drive itself is failing. If there is anything on the drive that you don’t want to lose I would recommend you back that up first. Next on your PC I would recommend installing “WD Drive Utilities” and running a full drive scan… perhaps twice. This may be able to detect if the drive is failing.

Thanks for the replies.
The drive is not powered and used for storage to play the video content on it.
I have started to back up and need to get a larger drive to complete that.
Thank you.

Then I suggest to use a powered USB hub.

If you are planning on replacing the drive, I’d suggest that you get a self powered drive unless you also want to get a powered USB hub.

Thanks again,
I will order a powered hub and see how that works and let you know.

Sorry for the delay with an update.
I just received my powered hub and put it in use.
No noises with the drive.

Many thanks for the help, fzinkin, darwindesign, and bmillham

1 Like

HI, just an update in case it might prove useful sometime.
My USB drive worked quietly with the powered hub, however my vero will not start when the hub and drive is attached, so I start the vero and then plug in the hub ,and it mounts and works great. Not a bother for me and better than replacing the drive but I thought you might like to know.
Thanks again for your help.

You mentioned in your first post that you were going to get a new drive. Have you done that yet? I suspect that your current drive is failing.

No I have not replaced the drive because it stopped making the noise when used with the powered usb hub .
Since I have been using the powered hub the vero will not boot up when the hub is Attached and plugged into a power source. but I can add the hub and drive after boot up.
My guess is that the power from the hub is interfering with the vero’s, boot process but I leave that up to the knowledgeable members here.
Thanks again , everyone.

Hello,
I have another question. When using the powered hub I have been having more difficulty starting my Vero 4K+ and my question : is it possible that this hub is the wrong power and not compatible with the Vero ?
I saw the OSMC store sells a hub and should I get that one to ensure that it will work correctly?
Thanks,

What USB port is the hub connected to on the Vero?

What exactly do you mean by

Have you tried plugging the hub into the other usb port to see if the issue goes away?

The hub is a generic model from Amazon and it has been plugged into the left ( outside) port. At first I booted the Vero and then plugged in the hub and powered it and it worked on the first attempt. Then it started shutting off during the process . Having the trouble starting is not so bad but I am concerned about ruining the Vero.
I will try the other USB port tonight and report. Thank You.

It would help if you explained exactly that the problem starting is. You say it won’t boot, but??? Do you see any messages on the screen when it’s not starting?