Usb weather station not working

Hello everyone ,
I have installed the following osmc version on my raspberry 3:
Starting Kodi (19.3). Platform: Linux ARM (Thumb) 32-bit
Release Kodi x32
Kodi compiled 2021-12-21 by GCC 8.3.0 for Linux ARM (Thumb) 32-bit version 5.10.78 (330318)

the problem is that now i can’t see my pce weather station connected via usb

osmc@osmc:~$ dpkg -l | grep -i libusb
ii libusb-0.1-4:armhf 2:0.1.12-32 armhf userspace USB programming library
ii libusb-1.0-0:armhf 2:1.0.22-2 armhf userspace USB programming library
ii libusb-1.0-doc 2:1.0.22-2 all documentation for userspace USB programming

With the previous version of osmc the station was connected…
any idea on how it solves?

thank you all


You don’t see it connected (e.g. with lsusb or dmesg) or you don’t see a driver for it being loaded?

I don’t see the station connected with lsusb and the weather software ‘pywws’ tells me that the weather station is not connected (‘Pywws’ uses this USB driver: python-usb - libusb-1.0 or pyusb).

I tried to connect the weather station via usb in windows and it works perfectly.

Have your tried it with Raspbian OS to ensure your Pi3 is fine?

No but I connected to the external sound card usb port and it works fine.