USB WiFi adapter Ralink RT7601 not work on Pi2

I’m new to this from linux. He recently installed the osmc for raspberrypi 2.
I have a wifi usb card that does not work for me with this distro.
Someone can help me to make it work.

Bus 001 Device 004: ID 148f: 7601 Ralink Technology, Corp.
But the device does not appear under “ifconfig -a”

Does it appear under lsusb?

But first you need to check out this post How to submit a useful support request and then get back to us.

Post the output of dmesg | paste-log
But it looks like the MT7601 chipset doesn’t have proper kernel driver which means you are out of luck.

Does it work with another Pi Distribution?

I’m not sure why you say that since a quick google search suggests that apt-get install firmware-ralink should install the driver.

But the OP never returned, so we can’t see if it actually works!

Well my quick google search just indicated that there is no kernel driver for that chipset. But my search might have been outdated

You’re probably right.

This link says the guy tried firmware-ralink without success. [SOLVED] Orange PI PC and $2 Ralink MT7601U dongle (USB ID 148f:7601) - Orange Pi PC - Armbian Community Forums but did manage to compile it. The source code link is still current.

Probably easier to get another WiFi dongle!

Yep, firmware <> driver

But the dmesg output can tell more

You’re absolutely correct. I’d assumed that the package would have installed both. That’s clearly not the case.

I now see that the firmware is already installed by default:

-rwxr-xr-x 1 root root 45412 Mar 5 20:58 mt7601u.bin

Just no driver, unless you self-compile. Curious.